• Level   1

    thanks hotchilli1327 for trying, but this is the exact account that ive been playing Dirt 3 with, as said, used a friends PC 2 weeks ago(or is it 3 now?) and it was working absolutely fine, did not use any other account for Dirt 3 than this, and di9d not set it to autologin. And my old PC was sold, after I did a proper killdisk of the harddrive and just made sure that any trace of old data was removed...

    • Level   V

    So you used a friends PC????  Did you make sure to remove your account???

    As always, Play Safe!

    • Level   1

    This is really irratating.  I have this same problem now.  Bought a new game and I can't sign into this forced stupid DRM GFWL.  I have done everything suggested in all of the forums for this error.. changed MTU, repair TC/IP, tried running with UPNP, tried running with it off and fowarding the ports, tried running them together,  added the MTU value to my adapter registry, uninstalled/reinstalled GFWL and the game, I can sign on the marketplace... sigh.. anyone ever figure this out.  I don't understand why developers make you use this crappy system.

    • Level   1

    And if you were wondering it says for internet connection and upnp that im not signed in.  I passed the tests for these things so i'm not sure what is up.  I'm using an actiontec router/modem.  I can connect to xbox live no problem, but not GFWL.  I recall it working about 3 months ago

    • Level   1

    Game Title - Gotham City Impostors

    Error Verbatim - Error: The LIVE service may be unavailable, or there may be an issue with your firewall

    Created a new GFWL account to play Gotham City Imposters, the game has not yet been activated with another account. Started the game and I am forced to log in to live if i want to play the game. So i logged in with the correct credentials, and it always gets stuck on downloading profile.

    a) I'm unable to download my profile in game

    b) I can log in from the web and the standalone GFWL application.

    c) I've port forwarded all the ports provided by the Xbox support page on my router

    d) I have disabled all unused network adapters and set my main adapter prioritized at the top

    e) I have updated Silverlight, installed Microsoft Essentials, updated .net framework to 4.0 and the latest GFWL client.

    f) I have ran the Microsoft Internet Connectivity test and there is nothing wrong with my internet configuration.

    g) I have already disabled my firewall.

    h) I reside in a Xbox live supported country.

    i) Error codes under the event windows: 0x80151907/0x80151907

    Where was the game purchased and in what format? Steam

    GT - MalibuJoJo

    PC/360 - PC

    ISP - Starhub

    Do you have a PPPoE or direct connection to Internet not needing to provide a username or password to connect? Use a router where I have to login to access it

    Conneciton Type - Cable through a router

    Router Make/Model/FW version - DLINK DIR-300

    Network Type - single pc to router

    Network Location - home

    Windows version? Windows 7 ultimate

    Press Start > Run >type WINVER > press OK - provide version and build number, if displayed.

    Windows System Type? 32bit

    Firewall / Security Software - using a combination router firewall? Vipre, disabled firewall

    LIVE Connection - have you ever connected to LIVE with a PC game in the past or is this your first attempt? Tried but always fail.

    Can you signin to LIVE with the LIVE Client for Windows (GFWL Marketplace)? I can log into the standalone app, hotmail, the web version.

    If you have more than one Games for Windows LIVE PC game, can any of those games connect? I have bought Batman Arkham City and GTA IV. None of them works

    • Level   1

    Issue Type - LIVE connectivity

    Game Title - age of empires online(but its LIVE generally)

    Error Verbatim - Well it sais it cannot extract from cab but on one post they said i should download it from GFWL so i tried and when i log in...i cant see my avatar it shows me 0 game points and it has error receiving my purchase history

    GT - GirlySoldier100 (if it means username then xmaniak100)

    PC/360 -I do not own xbox but my notebook can connect and do all this stuff

    ISP - T-Com

    Conneciton Type - fiber cable

    Router Make/Model/FW version - Belkin F5D8235-4 v2, latest

    Network Type - PC, wired(wireless avaible as well) and my notebbok is wireless

    Network Location - home

    Windows version?

    Windows 7 Home Premium 6.1 build 7601 and SP 1

    Windows System Type? 64 bit

    Firewall / Security Software - router firewall configured windows firewall turned off no anti virus firewalls

    LIVE Connection - Yea I did in games it works fine and on my notebook as well as i described

    Can you signin to LIVE with the LIVE Client for Windows (GFWL Marketplace)? partly as i described

    If you have more than one Games for Windows LIVE PC game, can any of those games connect?games can connect fine

    • Level   1

    Game - Dawn of War II


    "Cant sign in please try again later

     Code 80070005

    "WLID1.0 realm="WindowsLive" , fault= '"0x8015E226", pollicy="MBI_SSL", ver= "6.0.5286.0"

    recently i bought Dawn of War and the game wanted me to install games windows live, and i did but i cant login. it gives me this error. its really frustrating because i cant do anything in the game without login.

    • Level   1

    Issue Type - e.g. LIVE Connectivity

    Live connectivity: After successful signin to GFWMarketplace, Download tab shows all my titles, but attempts to download are stuck at 'Calculating download size' or 'Downloading 0KB of xGB'.  Previously installed GFWL games work fine (Bioshock2, BatmanAA).

    Game Title -

    Previously installed GFWL games work fine (Bioshock2, BatmanAA), I can access Live from within those games also.

    Error Verbatim - specific on screen Error and Event Log error

    After successful signin to GFWMarketplace, GFWM window sometimes shows "Error connecting to service", other times successfully loads the Store webpage.  Download tab shows all my titles, but attempts to download are stuck at 'Calculating download size' or 'Downloading 0KB of xGB'.  Previously installed GFWL games work fine (Bioshock2, BatmanAA).

    Detail the steps to reproduce the issue

    As above.

    Where was the game purchases and in what format?

    BatmanAA, FEAR2 & Bioshock2 Minerva's Den bought in digital format from GFWL

    GT - rmsrmsrms

    PC/360 - PC only.

    ISP - Centurylink DSL

    Do you have a PPPoE - yes.

    Connection Type - DSL

    Router Make/Model/FW version - QWest Actiontec PK5000 current firmware QAP002-

    Network Type - Ethernet Wired single pc to router/modem

    Network Location - home

    Windows version - Windows7 6.1 Build 7601 Service pack 1

    Windows System Type? 64bit

    Firewall / Security Software - Windows Firewall only, DSLrouter firewall disabled  

    LIVE Connection - have you ever connected to LIVE with a PC game in the past or is this your first attempt?

    I have connected and downloaded games in the past.

    Can you signin to LIVE with the LIVE Client for Windows (GFWL Marketplace)?


    If you have more than one Games for Windows LIVE PC game, can any of those games connect?

    Yes, previously installed games connect fine, it's downloading newly purchased ones that doesn't work.

    What I've attempted already:

    1) Installed & Uninstalled/Reinstalled latest GFWL package multiple times :)

    2) Windows Live account is valid

    3) Windows7 Service Pack 1 and all updates are installed.  Silverlight5 uninstalled/reinstalled.

    4) I reside in the US

    5) All tests in the Internet Connectivity Test succeed with Firewall Disabled.  All tests but UPnP succeed with Firewall Enabled.  Disabling the Firewall completely has no effect on the GFWM Downloading games problem I'm having.

    6) Portforwarding for Xboxlive enabled on router.  No effect enabled or disabled.  Router firewall disabled.  NAT type is Moderate according to Ingame Live Network Information, connected on port 3074.

    7) Windows Firewall shows GFWL & Client both allowed through, I also tried adding inbound TCP/UDP ports for 53,80,88,443,3074 to the firewall, this had no effect on the download problem.

    • Level   S

    rmsrmsrms It sounds like youve already done all the port fowarding necessary, but are you connected via wifi? If so, you will need to try a wired connection. Just because you show 5 full bars of wifi does not mean that the signal is clean. Try a wired connection to your Actiontec and try again. Aside from that there may be a 3rd party program stopping the dl from taking place. Double check to make sure you do not have any host programs or ip re-routers (ie remote desktop apps). If so remove them and try again. Good Luck.

    • Level   1

    Hey there, I purchased Gotham City Impostors yesterday and can't sign in the games for windows - live. It asks for the account name and pw, so I enter them, it tries to download the account and then returns:

    "The Live service may be unavailable or there may be an issue with your home networking equipment or firewall"

    I've tried every possible solution on the internet ranging from: MTU values, UPnP, ports, reinstalling, etc.

    The network status is a bit perculiar and I get:

    Internet IP Address: Not signed in

    System Link Address: Not Active

    UpnP: Not signed in

    I'm getting a bit frustrated, but I'd appreciated some help please.


    • Level   1

    Hello all,

    this might be usefull if you have trouble 'downloading your profile' the first time you login to live for a game:


    • Level   1

    Hi all, rmsrmsrms here, my GFWL downloading is working now, apparently from a seemingly unrelated "Fix It" update.  Today Windows Live Essentials 2011 gave an Update popup, which failed (and is still failing, hilarious!), saying "It looks like another program is preventing the installer from working" Error 0x80070643, so I ran a couple Fix Its  support.microsoft.com/.../971058  and support.microsoft.com/.../976982  trying to fix that, neither of which worked, but now my GFWL Marketplace downloads are working, hallelujah.  No other changes:  all the other fixes listed in this thread had no effect, not port forwarding, uninstalling/reinstalling, router or firewall settings, etc.  So I'm relieved, but forsee a complete Windows reinstall in my near future...hopefully there'll be a good SSD sale soon :)

    • Level   1

    Issue type: In game connectivity

    Game Titles: GTA IV, Microsoft Flight and virtually every game i've tried.

    Error Verbatim: Could not download the update. Make sure you are connected to the internet.

    Purchased: Local store

    PC/Xbox: Only Pc, no Xbox. PC LIVE: no

    Connection Type: Router LAN Cable

    Windows Version: Windows 7 32-bit

    Title Windows Flight.exe ( (Release.201) XLive 3.5.0092.0 (WGX_XLIVE_V3.05_RTM(panbldr).110928-1730) C:\Windows\system32\xlive.dll

    XLive Logon Failed


    LogonHR= 0X80072751

    Games For Windows - LIVE DLL

    My network supports everything except NAT. What to do ?

    • Level   V

    Did you try all the network trouble shooting steps?  There is no easy fix because most people will keep recommending the steps in the trouble shooting guide.  Please give it a read, follow the steps and see how it goes.

    As always, Play Safe!

    • Level   1

    Issue Type: In-game connectivity

    Game Title: Super Street Fighter IV (Steam)

    Error: VE6NA.jpg

    Purchased: Via Steam

    GT: HesARobot

    PC/Xbox: PC

    ISP: PPPoE (need user/password to connect to internet)

    Connection Type: ADSL

    Router Make Model: Netcomm NB6Plus4W

    Network Type: Singale PC to router/modem

    Network Location: Home

    Windows Vers: Windows 7 Home Premium 64-bit

    Firewall: Windows Firewall and Microsoft Security Essentials anti-virus

    LIVE Connection: This is the only GFWL game I own. Recently moved overseas to Australia, game hasn't been able to work since.

    I have tried the steps, it didn't work. Please help me. Thank you very much.