Can't connect to Live. Error code: 0x800705b4

    • Level   3

    My games are SF4 and SSF4AE for PC, and since last week I'm unable to connect to Live directly from the games.

    Error code: 0x800705b4

    Wireless: working for everything, except for the games' direct connection to Live

    Resetting network settings: tried this twice. Useless.

    Restarting hardware: I do this everyday. Makes no difference.

    When the error occurs: the games simply don't connect to Xbox Live. From Xbox.com and the Marketplace application I have no problem.

    Xbox Live Status: everything up and running

    Firewall or ISP blocking access: nothing. The games are in the exception list and the right ports are forwarded.

    Modem direct connection: equally useless. Tried it just now, to no avail.

    netsh ip reset: Useless. I tried it and did nothing.

    This problem is bugging me since last week. Can someone please tell me what's the problem?

    • Level   2

    Ansatsuken,

    If you wouldn't mind providing more information that would be awesome. What type of firewall are you using? What type of anti-virus are you using?

    Try to go here, www.microsoft.com/.../default.mspx and provide us the results of the test.

    • Level   S

    Do you get any text along with the error code you provided?  That error code does most definitely point us towards a network issue.
     

    I know you ran a tcp/ip reset, but have you tried the manual tcp/ip reset outlined in this article?
     

    You stated that you have ports forwarded for your games, but do you have all of the ports that GFWL requires forwarded?  It needs access to all of the following ports:

     

    Port 80 TCP

    Port 3074 UPD and TCP

    Port 88 UDP

    Port 53 UPD and TCP

    Port 443 TCP

    An article with more details on this is located here.

     

    The other critical piece of port forwarding is your static IP address.  Do you have a static IP set inside your PC that matches up with the IP you are forwarding ports to inside of the router?  Here is information about setting up a static IP.

     

    While you are signed into your router, see whether you have UPNP enabled or disabled in the router.  Turn it on if it's not on.  Your router will most likely have a hardware firewall in it, find this and turn it off.

     

    If you could provide your router's make and model in your reply, in addition to the results from the IDG test that Stonedboarder22 recommended, that would be great.  Also please let us know any and all security software that's on your PC.

    • Level   3

    The only line I see besides the error code is "can't connect to Live". And I tried exactly this test you mentioned.

    I forwarded the ports for the computer's very same IP, and UPNP is enabled, but even so it doesn't log in.

    Firewall: I use the default one from Windows itself. My modem (DSL-2640B) probably has its own, but I can't find it on its page.

    Antivirus: I use Avast free.

    • Level   3

    Sorry for the double post, but since I couldn't edit the previous one, here goes the evaluation tool's results:

    Basic Internet Connectivity Test: Supported

    Network Address Translator Type: Not supported

    Traffic Congestion Test: Supported

    TCP High Performance Test: Supported

    UPnP Support Test: Not supported

    Multiple Simultaneous Connection States Test: Supported

    • Level   3

    How are you connected wired or wireless? What is your routers make and model? Do you have x3watch, xfire, Himachi, Safe Eyes, Net Nanny, or Cyber sitter?

    • Level   3

    Clouddrinksjack, my router is a D-Link DSL-2640B. Using either wired or wireless makes no difference whatsoever. And no, I don't have any of these you mentioned.

    • Level   S

    The fact that your network is failing the UPNP test is a large piece of this problem.  When you run that test and it states that UPNP failed, what text do you get when you select view more details?  As a test, try to disable your port forwarding, while leaving UPNP enabled.

     

    Do you have AVAST completely disabled?  Do you have Windows Firewall turned off?  We need to get both of these services completely out of the way.

     

    Additionally, we need to get your hardware firewall disabled.  In your router, go to the advanced tab on the top.  Once you go into advanced, you will see a category labeled Firewall/DMZ on the left hand side.  Turn the firewall off from there.

     

    Let us know what happens after you perform these steps.

    • Level   3

    It says that the tool "failed to find any Internet Gateway Devices".

    By the way, I don't know if this changes much, but when I used Windows Vista, this problem did not occur, even with AVAST and Windows Firewall enabled. All I had to do was forward the ports and make my IP the DMZ host.

    Now that I formatted the system and put Windows 7, under the same conditions, the game doesn't connect to Live, although I can sign in normally through Xbox.com and the Marketplace application.

    • Level   S

    Sorry Ansatuken, I should have been more specific.  When the test completes, click on view detailed report (down near the bottom) and you'll see specifics for each test result.  Please copy and paste the text from the UPNP and NAT test results in your post.

     

    If your PC was DMZed before and it's no longer in a DMZ, this is an extreme change in your network setup, since being DMZed essentially leaves all of your ports open to access from the broader internet.  Have you changed any other network settings or hardware since this problem started?

     

    Did you get a chance to try the other steps above?

    • Level   3

    I've forcefully reseted my router, DMZed my PC again, and "manually" forwarded the ports (just in case, who knows...). Unfortunately, the game now says it's firewalled.

    The evaluation tool had some good changes: the previously unsupported tests (NAT Type and UPnP) are supported now. Everything went OK, but my IGD's NAT type is labeled as RESTRICTED CONE. Could this be the problem's source now?

    • Level   7

    Try the TC/IP reset if you are confident that your network is setup correctly, and you pass the important tests. Everyones NAT type can come up different, but it is not a deciding factor when connecting.

    • Level   3

    InGlocksWeTrust, if you're talking about the netsh ip reset, I've already tried it, to no avail.

    About the evaluation tool, I've ran it now. As I suspected, my problem must be in the wireless connection.

    By using wired connection, all tests run OK (except the NAT type test, which only came up OK when my IP - which is not static - was the same as the DMZ host... although I don't know whether or not this was coincidental).

    Using wireless connection, not only NAT type fails (the test labels it as SYMMETRIC), but UPnP support as well (finds no Gateway Devices). I suspect that this is a driver issue, be it either compatibility (this problem bugs me ever since I formatted the system) or wrong configuration. Any suggestions?

    • Level   3

    I highly reccomend taking away that DMZ. DMZ is good for your xbox not so much for a PC. DMZ embraces more firewalls and adds them to the computer. The key here is to take away those firewalls. Now since you are going into a router is it possible to completely skip the router and do a direct to modem connection?

    • Level   3

    Actually, I have just one modem here (I call it a router for pure bad habit). My notebook doesn't even connect to the Internet without connecting directly with it.

    The weird fact is that the game logged in once last week, without any changes to the connection's config. This appears to be random, leaving me even more confused...