Age of Empires Online FAQ

    • Level   7

    Age of Empires Online FAQ

    System Requirements

    • OS: Windows XP® , Windows Vista® , Windows® 7
    • Processor: 2.0GHz Intel® (any dual core)
    • RAM: 2GB
    • Video Card: 128MB
    • Hard Drive Space: 2GB

    Game Capabilities

     

    • Online Multiplayer 2-4
    • Co-op 1-2

     

     Age of Empires online is free to download and play. There is additional premium content for purchase in game or in the Games for Windows LIVE marketplace.

     

     

    Questions

    Q. Why can’t I buy items in-game?

    A. Currently, if you reside in Brazil, Chile, Columbia, Czech Republic, Greece, Hong Kong, Hungary, or South Africa, you are unable to purchase civilizations, booster packs, vanity items, or bundles through the Age of Empires Online store found in the game. Until this issue is resolved, please make your purchases via the Games For Windows – ­­LIVE client, which can be downloaded at: http://www.xbox.com/en-US/Live/PC/DownloadClient.  Once you download this client, you’ll be able to make your purchase through the Marketplace tab. Please be assured we are working to fix this as fast as possible.

    Q. Where can I get the digital game manual

    A.Check it out here: www.ageofempiresonline.com/empirehandbook


    Q. Where is the Offical Age of Empires Site?

    A.Official site is located here check it out http://www.ageofempiresonline.com/

    Official forums are located here stop by and say hi http://forums.ageofempiresonline.com/forums/

    Q. How do I find my Game Key?

    A.In order to obtain your Key ... You need to be in the Games for Windows Marketplace > Click on "Downloads"

    Click on "Age of Empires Online" >Click "View Game Keys"

     The Following I have taken directly from the AGE ONLINE FORUMS http://forums.ageofempiresonline.com/forums/thread/88652.aspx Thanks Ryz0n !

    Support and Troubleshooting FAQ:

    Having trouble installing or running Age Of Empires Online?  This FAQ thread contains information on common problems and resolutions for users.  We will be continually updating this thread as new issues / resolutions arise.

     

    Installation Issues

     

    Beta Users:  Remove the Beta from your computer before installing Age Of Empires Online:

    Beta installations of the game can on occasion interfere with the downloading and launching of the retail game.  Please make sure to remove your beta installation prior to running Age of empires Online

     

    The LIVE service is not supported in my country

    Age of Empires Online requires a LIVE gamertag created in a supported region.  To see a list of LIVE supported regions, please visit http://www.xbox.com/en-us/live/countries .  While users who live outside the supported regions may be able register a new gamertag within a valid region, please be aware doing so will limit the support that can be provided to your account.

     

    Problems with gfwlivesetup_4D530FA3E0000001_DIR.exe.
    OR
    A network error occurred while attempting to get information from the server / Install failed

    This error can occur when you attempt to download and install Age of Empires Online using the web installer. You can resolve this issue by manually installing the Games for Windows – LIVE client and then downloading the game through the Games for Windows Marketplace.  Please follow these steps if you encounter this problem:

    1. Uninstall the Games for Windows - LIVE client through the computer control panel if it is already installed.
    2. Download and install Games for Windows – LIVE from this link: http://www.xbox.com/en-US/LIVE/PC/DownloadClient
    2. Login using the same gamertag you used to redeem the code.
    3. Navigate to the Downloads section to download and install Age of Empires Online.
    4. Run the game as administrator.



    Game Launcher / Update Issues:

     

    ‘There was an error’ while updating the Age of Empires Online launcher

    This error when you failed to pull a specific file from the servers. User’s experience this issue should first attempt to clear their temporary internet files and restart their computer. Try the following solutions if this error occurs regularly:

    1. Run a full scan to replace all files. To do this select ‘Options’ on the navigation bar on the top of the game launcher, then select ‘Full Scan.’ 
    2. Open the Window OS task manager and check for a process named conime.exe*32.  End this process if it is currently running. 
    3. Create a new Windows NT user account, download and install the Games for Windows LIVE client, and test to see whether you can run Age of Empires Online.
    4. This issue may reflect a large problem with your network settings. You should read through this Games for Windows LIVE troubleshooting thread: Connection Issues FAQ 

     

    ‘Cannot find Spartan.exe file’ at the Age of Empires launcher

    To fix the ‘Cannot find Spartan.exe’ error you should run the launcher, click on the ‘Options’ drop down, and then click on ‘Full Scan.’  
    When downloading / patching the game, the update fails at scenario.bar
    If you previously experienced an issue with the launcher failing while attempting to download scenario.bar;
    Run the launcher
    Select “Full Scan” from the options menu if the launcher does not automatically update.  If you’re still having trouble, let us know what region you are in at this time.

     

    The Granny2.dll file is corrupt or cannot be found message at the launcher

    To resolve the error message ‘The granny2.dll file is corrupt’ or ‘The granny2.dll file cannot be found’ message at the launcher select “Options” and choose “Full Scan” from the drop down menu. Run Age of Empires Online as Administrator.

     

    The spartan catalog file is corrupt | The launcher disappears after the black “Updating Patcher” window opens

    Run a full scan by selecting “options” and “Full Scan” in the Age Of Empires Online Launcher. If unable; (Full Scan Greyed out) one of our forum users has suggested the following workaround that appears to be working for many users.

    The work-around steps are as follows:
    1. After installing the game navigate to your installation folder.  This is usually C:\Program Files\Microsoft Games\Age of Empires Online\ for 32 bit systems or C:\Program Files(x86)\Microsoft Games\Age of Empires Online\ for 64 bit OSes.
    2. Navigate to the “patchTemp” folder inside the Age of Empires Online folder.
    3. Select all files in your patchtemp folder and copy them. 
    4. Navigate ‘up’ back to the Age of Empires Online Directory
    5. Paste the copied files into the Age of Empires Online directory and select “Copy and Replace” for all files.
    6. Run Age of Empires Online as Administrator
    .

    ‘An instance of the game is already running’ error message at the launcher

    This error occurs as a result of the game failing to launch due to improper system permissions.  Please follow these steps if you encounter this error message:
    1. Launch the game as an administrator from your computer. If this doesn’t work follow steps 2-4:
    2. Uninstall just the Games for Windows - LIVE client through the computer control panel.
    3. Reinstall just the Games for Windows - LIVE client from this link: http://www.xbox.com/en-US/LIVE/PC/DownloadClient
    4. Reinstall Age of Empires Online from within the Games for Windows - LIVE client.
    5. Navigate to the directory where you installed the game and run the launcher.exe file as an administrator.


     


    Game Launch / In Game Errors

    Invalid product key in-game | Error 0x80070003 when entering LIVE product key in-game

    Anyone that purchased the retail version should note that the LIVE Access Code is NOT the same code as the one included in the box

    This error message occurs when the game fails to load your LIVE Access Code.  Please follow these steps to resolve this issue:

    1. Log into your Games For Windows Marketplace client.
    2. Click the Downloads tab.
    3. Click the icon for Age of Empires Online.
    4. Click View Game Keys.
    5. You will see a numerical code under LIVE access code. Enter this code when prompted in-game. 
        If this doesn’t work, follow steps 6-8:
    6. Search for Windows Update from the start bar and click Check for Updates.
    7. Run any necessary updates and restart your computer.
    8. Run Age of Empires Online again.

    More detailed support for this issue can be found here: http://support.microsoft.com/kb/978129

     ‘APPCRASH’ encountered when you first launch the game

    If you run into an APPCRASH when first loading up the game restart your computer and re-launch the game as administrator.
    Game Initialization Failed | D3D initialization Failed
     Possible Causes
    · Video card driver is out of date or corrupted.  Install the newest driver.
    · Video card is below minimum requirements
    · Direct3D is not properly installed.  See the following support article: http://support.microsoft.com/kb/179113
    · Hardware Acceleration is disabled on the video card
    · Application started with the workstation locked

     

    Status Code:800700e8 Can't retrieve information from LIVE. Please try again later.

    Errors may occur caused by any of the following issues:
    · Applications or processes that interfere with Internet communications
    · Resource issues on your computer
    · High Internet activity
    · Recoverable database errors
    Please follow the resolution steps on this page: http://support.microsoft.com/kb/836941

     

    LF004 error when signing into Age of Empires Online

    This error code means that you are attempting to connect to a shard that is currently unavailable.  If you experience this issue, you should check the server status forum for any updates about the issue.  We appreciate your ongoing patience as we resolve any server issue. Thank you!

     

    Error Code: 80070652: Install of Item Failed

    If retry fails, delete the item and re-download it.  We have had several reports that report that installing the sign-in assistant resolves the problem.  The Live sign-in assistant can be found here: http://www.microsoft.com/download/en/details.aspx?id=26686

     

    Random Map: Scenarioloader Caused An Unhandled Exception

    Please see the following link for a resolution for this issue:  http://forums.ageofempiresonline.com/forums/thread/49127.aspx


    Screen issues – Half or Partial Screen Showing

    Change the game between full screen and windowed mode should alleviate common display issues.  Press Alt + Enter to switch between windowed and Full Screen mode.

    Games for Windows Live related issues:


    “What ports need to be open to run Age of Empires Online?”

    The following ports are required to be open to successfully play Age of Empires Online through the Games for Windows LIVE platform:

    TCP 80
    UDP 88
    UDP 3074
    TCP 3074
    UDP 53
    TCP 53
    TCP 443

    These ports need to be accessible through both your firewall and your router.  For more information about opening ports on your router you should consult the instruction manual.  To open ports in Windows 7 you should follow these instructions:

    1.    Navigate to this path Control Panel > System and Security > Windows Firewall
    2.    Go to the ‘Advanced Settings’ on the left side of the window
    3.    Right click on ‘Inbound Rules’ and select ‘New Rule…’
    4.    Choose to create a new Port rule
    5.    Select either UDP or TCP and specify the port
    6.    Repeat steps four and five until you have made rules for all the listed ports

    For more information about your current networking settings you can run the Microsoft internet Connectivity Evaluation Tool found here: http://www.microsoft.com/windows/using/tools/igd/default.mspx


    “How do I make my offline profile a LIVE enabled profile?”

    To make your offline profile a LIVE enabled profile you can click Messages, Friends, or Players, and then click Join LIVE. If you don't have a profile yet, click Create New Profile, and choose Create LIVE Profile.  

    Games for Windows LIVE error code 8015403A

    The Games for Windows LIVE error code 8015403A currently links to the wrong website.  You will need to manually sign in at xbox.com using your same Games for Windows LIVE email address and navigate to the account management screen where you will be prompted to accept the new LIVE Terms of Service.  Once you have accepted the new Terms of Service, you will be able to successfully log into the Games for Windows LIVE client.


    Games for Windows LIVE Technical Support Forums

    If you’re having issues with the Games for Windows LIVE client, then the GFWL Technical Support forums can be an invaluable resource.  Here are some threads that have been helpful to many community members experiencing issues with the GFWL client:

    Games for Windows LIVE Technical Support forums
    Connection Issues FAQ
    LIVE Connect Issues – Cannot Connect to LIVE
    LIVE Troubleshooting – Things to Try First


    General PC Gaming Best Practices

    PC gaming requires that users maintain up-to-date software and hardware drivers.  Occasionally, critical software and hardware drivers do not get updated properly and it prevents us from playing our favorite games. If you’re new to PC game troubleshooting, below are some best practices to maintaining the best PC gaming experience for ANY game played on the Windows operating system:

    Install the latest video card drivers – Nvidia or AMD 
    Install the latest Windows Service Pack – Web Installer
    Install Microsoft .NET Framework 4 – Download Installer
    Install Microsoft Visual C++ 2010 Redistributable – Download Installer
    Install DirectX 9.0c or a newer version of the end-user runtime – DirectX 9.0c Web Installer
    Enable Universal Plug and Play (UPnP) on your router

     

     

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   1

    i downloaded it, installed it, created windows live account, went through twenty glitches to get into windows live marketplace, created a new email, created another account that worked, just to be asked for a product key I WAS NEVER GIVEN!!!  The choose "need product key?" to end up in windows marketplace where it tells you NOWHERE HOW TO GET THE PRODUCT KEY FOR A FREE GAME YOU DOWNLOADED!!!!  someone please explain this

    • Level   7

    can you please read the part above of where to obtain your key

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.

     

    • Level   6

    And when will the in-game marketplace issue resolved?

    • Level   1

    I can't even get the game to install. I updated everything and yet it still says "Failed Install"

    • Level   2

    Any plans to make this work better with an xbox in the house?  My family likes to watch netflix on my gold account on the xbox which prevents me from playing AoEO on my PC.  I had no idea this issue existed so now I've pretty much wasted $40 I can never use!

    If a service rep would be able to transfer my paid content off my gamerid to a different one, that would be acceptable but this is unbelievably stupid from a company who is trying to integrate the PC and XBOX.

    • Level   1

    Im unable to purchase any premium content. It keep saying:

    "Sorry

    An error has occurred during the transaction. Please try again later."

    After I have authorized the payment. I have tried paypal and credit card.

    • Level   1

    Despues de instalarlo todo , crear mi cuenta en windows marktplace comprar en la tienda por 19€ la expansion de los griegos... etc etc.. el juego no funciona se queda en la pantalla de iniciar el juego , y hay se queda... muerto... 

    Saludos.

    • Level   1

    Somewhere between "Installation success" and sign in I get a launcher that is not doing anything. A lot of the stuff is greyed out. The firewall looks ok, I'm on a Win7 with the lastest stuff from Win Update. What the hell.... My brother texted me and said that he's playing it fine.

    • Level   1

    For some reason it keeps saying that my windows-live id doesnt exist....anyone know a solution for this? My brother's profile plays fine on this same computer and everything so i'm pretty lost on what to do.

    • Level   1

    been trying to download the free game for about 6 hours now on off and every time i get

    "Sorry

    An error has occurred during the transaction. Please try again later."

    how much later should i wait? is this down to huge ammounts of traffic or is the marketplace just pants? any help would be greatly appreciated.

    • Level   1

    I live in Tunisia(Africa) and I just brought the premium civilization of AoE online from the in-game store but whenever i try to download it using Marketplace it gives me the  "80004003 try to start the download later" error message.

    Please can anyone help me?

    • Level   1

    how do you access "games for window live marketplace" I have backed out of the product key window and clicking on either "martketplace" or" live" on the games frontpage simply takes me back to the enter product key window. I have spent 2 hrs trying to load and trouble shoot this game. Why does a FREE game need a product key!

    • Level   1

    I downlaoded the game, then installed it, but when I launch it, I have the launching window, but I can't press the button "play".

    It's so sad, I wanted to buy all the other content, but with something so well implemented, I think I'm going to spend my money in other games that really worth it...

    • Level   7

    Play Button Not Working - Try Right Clicking and running the Launcher or the Games for Windows Marketplace client as an Administrator

     

    Uh oh... that shouldn't have happened.

    It appears you've found a glitch in the system.