QUALCOMM/Killer Network Manager

    • Level   1

    This post is for those of you that are having problems signing into Games for Windows Live with the Qualcomm/Killer Network Manager. If you have the Qualcomm/Killer Network Manager. Please do the follow.

     

    Windows 7/Vista

    Please Click on Start and where it says search for programs and files please type in cmd . When the Command Prompt appears under Programs please Right Click on it, select 'Run as Administrator'. Then once your command prompt opens up please type in the following.

    netsh int ip reset resetlog.txt (then press enter) should go through the following

    Reseting Interface, OK!
    Resetting Global, OK!

    Restart the computer to complete this action.

    Then I want you to type in netsh winsock reset (then press enter) should go through the following

    Sucessfully reset the Winsock Catalog.
    You must restart the computer in order to complete the reset.

    Then go ahead and restart your computer.

    Upon restart, you now should see the QUALCOMM/Killer Network Manager popup and display

    The layered service provider is not mapped correctly, do you want to remap? You going to want to click 'no'.

    The next step for this issue is to go ahead and disable the startup of the program. You can do this by the following

    Click on Start, where it says 'search for programs and files' type in msconfig

    Once msconfig loads on the top of the program your going to want to click 'startup'

    Go through the list until you see QUALCOMM Network Manager and uncheck the box. Then select 'apply' and 'okay'. Now go ahead and restart your computer.

    You issue should now be solved and you shouldn't have anymore problems logging into Games For Windows Live.

     

     

    • Level   1

    You my friend, are a life saver. You have no idea how much time I put into solving this problem, and to find out that this was the cause, I am beside my self. Thank you so very very much.

    The question I want to ask now is why this was in fact the problem, I'm no computer specialist or anything but it would be a bit of a relief to know why this was happening.

    • Level   1

    The reason for this, as far as I can tell, is the Layered service provider.

    A Layered Service Provider is a DLL that uses Winsock APIs to insert itself into the TCP/IP protocol stack . Once in the stack, a Layered Service Provider can intercept and modify inbound and outbound Internet traffic.

    Hence why it's interfering with GFWL authentication, as it is inspecting/intercepting/modifying the inboud and outbound traffic.

    • Level   1

    You sir, are a god among men!

    • Level   1

    Thank you so very much Stoneboarder, I have been trying to fix this for over a year! I can't believe how contrived gaming has become. It's reached a point that you need to be an IT technician just to play these days.