Dead Rising 3. Still looking for advice on a problem.

    • Level   2

    My copy had an update today and hasn't worked since. It allows play for exactly 25 seconds and then throws me out of the game.

    Anybody else had this problem? Could it be update or game related? The game has been looked after and does not appear to have any damage.

    • Level   1

    Have you tried uploading your saved game to the skydrive then deleting the installation file from DR3, and then reinstalling everything?

    I know it might seem like a pain but it might work, again, BE SURE to upload saved game to the cloud to not lose any progress before attempting this.

    • Level   5

    did you start the game before the update installed 100%? you get a message saying you can play the game before the update fully downloads and installs. that messes up your save file. why anyone would be allowed to play a game before it finish's updating is weird.

    THE IMMORTAL D is currently waiting for MORTAL KOMBAT X