No 3d?

    • Level   2

    I just bought Doom 3 BFG edition for xbox but there is no 3D option in the settings menu. The manual says it should be there but its not. Anyone know how i can fix this i really want to try this in 3D.

    • Level   1

    I've been having this problem myself, and I just solved it about 10 minutes ago. Turns out, you need to turn off 'display discovery' in your system settings. Once your console has rebooted, go select the screen resolution in the settings. Then, the 3D option should appear in Doom 3 BFG Edition. ;)

    • Level   2

    Has stated above I personally believe it should be more clear on how to get it working !. Can not wait for mine to arrive in the post !

    • Level   1

    I'Ve been having the same problem.. I've messed around with my tvs auto detect 3d setting , but I've had no luck... Looked all through the game settings and no 3d option... Anybody have any help or similair problems???

    • Level   1

    bump...

    • Level   1

    guys i know this is an old thread but just to let you know i picked up a copy of this today and the turn of discovery disply option cure for this problem worked a treat for me thank you so much