Bought 40k gold, received 0 gold? Glitch?

    • Level   4

    Hey, I don't have a lot of time to play video games these days, and since there's really no leveling up in CA to justify replaying levels multiple times I thought I'd save myself the trouble and download the 40k gold (Since it's a cheap 80MS Points).

    SO I downloaded the "Rags to Ritches" thing for 80 points and nothing.  Nada, zip.  What am I doing wrong? Do I have to go to something in-game and activate the 40k?  Did Microsoft just steal $1 from me?

    Help appreciated.

    • Level   4

    I purchased the points in-game via the "Merchant: Outlawed Ordnance" area.  I also quit out of the game and checked my active downloads, and there's nothing.

    And checking my system's memory the "Rags to Riches Pack" is there.

    • Level   4

    OK nvm, problem solved.  I guess it takes like 20 minutes for the thing to unlock?

    • Level   3

    I used the 80 of the 100 points I had left after buying the game on this and it worked instantly for me. I just clicked download, it completed in under a second due to the small size, and then I unlocked the chest and that was it done. You need to actually activate the chest again after the download, did you do that?

    Either way, at least you got it sorted.

    Shut It Ya Bass!