This question has suggested answer(s)

" Dust: An Elysian Tail " Crash

  • Level   1

I've bought the " Dust: An Elysian Tail "

but when I start the game, it crash and keep sending me back to the xbox live lobby..

My HDD is 250Gb ver, and it has about 20Gb free space, so i don't think this is my HDD problem..

I have tried many ways to fix it,

I have tried:  copy my Xbox live account to a memory stick ,

then,  delete the game , remove the HDD,

reboot the console, re-download the game to the memory stick ,

IT STILL CRASH...

don't know what else can do..  please help. :(

I LIVE ALL I AM

All Replies
    • Level   7

    Hey,

    There are quite a few troubleshooting steps here.

    Try clearing your system cache and marketplace cache. it explains how to do both plus other steps in the link I provided. Let me know if any of it works 

    Ahhh, the sweet smell of pigskin is in the air. E-A-G-L-E-S Eagles!!!

    @1brandiesel

    • Level   1

    Tried clear my system cache and marketplace cache..

    Deleted the game and download it again.

    But it still crash and it sends me back to the xbox live sends again..

    I LIVE ALL I AM

    • Level   1

    Hi PAL In XBOX360. Clearing your system cache will help But you may have corrupted files in the download.It will show as a yellow  symbol delete everything with a yellow symbol.

    Xbox Live Ambassador .

    • Level   1

    thanks for the help..but no.. I can't find any corrupted files in the HDD..

    I've checked it twice..

    I LIVE ALL I AM

    • Level   1

    Try re-downloading the game completely from the Marketplace again, and not from your memory stick. Also try signing out of xbox live when you start the game, then sign in once in your the menu.

    Some crashes have been reported to Noogy (the developer) but I haven't seen anything along the lines of being this extreme. If you have a Twitter try reaching out to @NoogyTweet, or email him at noogy@noogy.com and let him know about the issue. I know he's working on a patch for the reported problems, but if this is still a serious problem he may speed up the release.


    My opinions are not supported by Xbox or Microsoft and I am only here to assist you in finding a solution for you.

    • Level   1

    I am having similar problems.

    Opening treasures is extremely glitchy for me. The buttons oftentimes do NOT work, and I have to try several times, sometimes by pressing the correct button several times. Sometimes it will not register button presses at all.

    Now in addition to that, my game will crash to home screen while trying to open treasures. Not all the time, but a lot. I am thinking of not playing anymore because it is frustrating to lose time and experience and all you've done in between saves.

    I have done everything including starting a new game (deleting game, redownloading, clearing cache, etc). It seems to be getting worse!

    • Level   7

    I was just reading a few reviews of the game and the reviewers had some of the same issues as you guys. Maybe they will put out a patch to help resolve them.

    Ahhh, the sweet smell of pigskin is in the air. E-A-G-L-E-S Eagles!!!

    @1brandiesel

    • Level   1

    I hope so,

    even today, i can only see the black screen for about 10 second before it sending me back to arcade menu..

    I LIVE ALL I AM

    • Level   5
    • Suggested Answer

    I think you will get news about this quicker if you go to the forum just for DUST which is at forums.xbox.com/.../2526.aspx

    especially since this is a problem, not with downloading or purchasing, but with playing just this game.

    Support: tinyurl.com/XBLnumbers or Request A Call support.xbox.com   How to get FreeLIVE j.mp/XVriY7