This question is not answered

Kingston DataTraveler G3 16GB not seen by XBOX 360 S

  • Level   1

When I look at storage devices in:

‘Settings’ Hub > ‘System’ Tile > Storage

I only see the internal Hard Disk and the Cloud Saved Games. It doesn't matter if I plug the thumb drive in before turning on the console or plug it in after the console is started. I have used other USB memory sticks successfully with my console. The DataTraveler is formatted with a single MBR partition (normal DOS/Windows style) which is formatted with FAT32, but I don't think format is the issue since it is not seen at all and the XBOX should offer to reformat it.

Is there a trick to get this memory stick to work?

All Replies
    • Level   S

    Hey there Esjay! Just a clarification before we start, formatting on the console is different from formatting it to FAT32 on a PC. If you haven't recently, I would recommend formatting it again on your PC to FAT32 and try again. Also, if you have the ability to, try testing it on another console to see if you get a consistent behavior. Let me know what you find out, thanks!

    • Level   1

    As far as I can tell, the Xbox just doesn't have a driver for this thumb drive. I tried it on a friend's console and had the same result. I tried reformatting it several times on my PC, but it didn't help. If the console can't see the device at all, there is no way to get it formatted as a memory unit. Is there a compatibility list somewhere?

    • Level   7

    There hasn't been a list in the new forums and the old compatibility thread by users is gone

    I'd go by USB 2.0 and ready boost compatible

    Anything but cheap 20 dollar drives  depending on size of course