This question has suggested answer(s)

Can't load up my Xbox 360 Dashboard!

  • Level   4
Hi,whenever I turn on my Xbox 360 Elite the Dashboard takes ages to load up. I've tried deleting my cache but it still doesn't load up, help!
All Replies
    • Level   S

    Hey ArchAngel DP!  That definitely does not sound fun.  Please post a fresh thread about this and we'll be happy to help out with it!

    • Level   4

    Bump

    • Level   S

    Hey there Pro4TLZZ!

    I see you've been asked a couple times if you've tried any of the previous suggestions in this thread. Your posts are just telling us that the issue is still there but they're not telling us what you've tried.

    Please look back through this thread at all of the great suggestions and give them each a shot. When you try them, be sure to post what the suggestion was that you tried and what the results were when you tried them.

    That way we know what you've tried, how it went, and we can suggest things to try next. ^_^

    • Level   3

    Do you have a network connection on? Disconnect the ethernet cable or wifi, it should boot straight to dash when there is no active network.

    (Assuming you have this connected, if not, then try the other steps as mentioned)

    Follow: twitter.com/romeoteknik

    • Level   4
    • Suggested Answer

    bump

    • Level   S

    G'day Pro4TLZZ!

    Be sure to try the suggestions that have been posted so far and let us know the results. Thanks!