This question is not answered

Constant Disconnecting from XBL

  • Level   2

When I turn on my console it immediately connects to Xbox Live no problems. Its when i play a game that the issue arises.

One of three things will happen. Either I will disconnect from XBL during the game's loading screen, I will disconnect during the matchmaking, or I will join a game and be disconnected within a couple of minutes. I have tried this with a number of different online games and they all yield the same result.

After I disconnect I run the network test and it says everything is fine. I try to reconnect immediately and it says it can't. 9 times out of 10 I have to restart the console just to reconnect to XBL. Upon a restart it immediately reconnects and starts the process over again.

I have tried all the usual solutions, even bypassing my router and plugging straight into my modem and this hasn't changed anything. No other device on my network has any problems with internet connection. Everything had been working fine for the previous 6 months, it has only been the last two or so weeks that I have been having this problem.

Here's some info:

What Country/State/Province do you live in?  Australia

Modem brand & model number:  Linksys WAG320N

Router brand & model number:  N/A

Is UPnP Enabled? Yes

Do you have a NAT error? If so, what is your NAT? No, its set to Open

Any Error Codes you encounter:  None

Who is your ISP(Internet Service Provider)? Iprimus

After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown?

W: 0000-000B

X: 0000-F001

Y: 20A8-4840

Z: 0000-0000

ID: FFFF-FFFF

L: 8015-1904

Q: 8015-100c

T: Wired

A: 192.168.1.100 / 255.255.255.0

G: 192.168.1.1

D: 203.134.64.66 / 203.134.65.66

Thanks in advance

All Replies
    • Level   S

    Hey there Coemans! I understand you are having some issues staying connected to LIVE when starting a game. To clarify a little bit, does this happen with all games? How about when you start up apps like Netflix or Sky? Do you ever notice any disconnecting when just sitting on the Dashboard?

    One thing that can sometimes help when the disconnecting is happening right when you start up a game is to download your profile again. If you need steps, you can find there here (forums.xbox.com/.../153143.aspx). Please try this out and let me know how it goes. Thanks!

    • Level   2

    Hey Gwyther,

    Yes this disconnect does happen with all games, even offline ones such as Portal 2. And yes it does disconnect after about 20 minutes or so if I leave it on the dashboard. I never use my Xbox for Netflix or Sky or anything other then games.

    I tried redownloading my profile and that also had no effect.

    • Level   4

    I am having the exact same issues since the last update.

    • Level   S

    Thanks for the reply Coemans! I'm sorry that didn't work out for you. After looking through the test results you posted earlier, I would like to suggest checking out your DNS settings and making sure all this is set up properly. Please follow along with the steps listed here (forums.xbox.com/.../191860.aspx) and post back with the results. Thanks!

    Lone: In order to better assist you, we'd like you to create a new thread in this forum detailing your issue and any steps you have already tried. Thanks!  

    • Level   2

    Howdy,

    I followed those steps and I am still getting the same problems.  I'm still plugged directly into the modem and not going through a router.

    • Level   X

    Hey c0e - just to be clear on something in your original post, you mention that you are unable to sign back in unless you restart the console, but also mention that the connection test always says everything is fine. Are you always able to connect to LIVE if you run the connection test?

    • Level   2

    Portia,

    Yes i am always unable to reconnect to Xbox Live unless i restart my console, even if the network test says everything is fine. I run the network connection test, it says there are no problems connecting to Xbox Live, so i press the home button, select Connect to Xbox Live at which point it cannot establish a connection and asks me to run the network test again. Only if I restart my console can I reconnect.

    • Level   X

    Okay, that's helpful! Thank you! When you get the error message after running the connection test, is there any other information on it? Such as an error code? Also - do you have another account you can test with? I'm curious if you have the same issue on multiple accounts. Thanks!