This question is answered

Disconnecting from Xbox Live while watching Hulu and Netflix

  • Level   1

Everything had been working fine for months, but then starting a couple of weeks ago, I started getting disconnected from xbox live while watching Hulu and Netflix.  It interrupts playback and tells me that I must upgrade to xbox live gold in order to watch.  I have gold, and it doesn't expire until mid-April. 

I can immediately sign back in and begin watching again, but the error always happens again within minutes - I can't ever seem to watch for more than 10 minutes without the error, and it usually happens more often than that (every few minutes).

I have tried all of the suggested solutions I've seen - I deleted the apps and all their data, deleted my profile, cleared the cache, power cycled my cable modem and router, and reinstalled everything.  Upnp is enabled on my router and I can see that the ports are forwarding as expected..  I use a wired connection and have 30 mbps internet.  I am able to stream without issue is full HD when I use the Netflix or Hulu apps on my Samsung tv directly.

I've seen similar posts here... is there a solution that is working for anybody?  This is very frustrating, and the problem seems to have come out of nowhere.

Here's my info from running a network test after the issue (the network test always passes).  Any help would be much appreciated!

What Country/State/Province do you live in? USA - Portland, OR
Modem brand & model number: Motorola Surfboard SB5101
Router brand & model number: Asus RT-N16 running DD-WRT v24sp2 mega firmware
If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? n/a - using wired connection
Things you have tried: 
Is UPnP Enabled? Yes
Do you have a NAT error? If so, what is your NAT? no NAT error
Any Error Codes you encounter: 
Who is your ISP(Internet Service Provider)? Comcast (Xfinity)
After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W: 0000 - 000B
X: 0000 - F001
Y: 20A8 - 4840
Z: 0000 - 0000
ID: FFFF - FFFF
L: 0015 - 10F0
Q: 8015 - 100C
T: WIRED
D: 192.168.1.1/0.0.0.0
S:
C:

Verified Answer
    • Level   X
    • Verified Answer
    • Verified by

    Ah, excellent! That means we are now confident there is a configuration issue with your router that we can help you with. :) You mentioned that you have UPnP enabled, as well as Port Forwarding - is that correct? If so, that may be contributing to the cause, as they often do not play well together. We would suggest trying UPnP alone, or perhaps disabling UPnP and using strictly Port Forwarding. You can also try opening your ports completely, or even try a DMZ as a last resort. Unfortunately I am not familiar with your router's firmware to be able to provide these steps, but I would encourage you to see if there are support documents available that could walk you through the steps. Sorry I can not help further!

    Emily - Program Manager @ Xbox, Xbox One Preview Program

All Replies
    • Level   X

    Hello david! Thanks for your post. :) I'm sorry to hear you are having this issue! You're right, the results from your connection test show nothing out of the ordinary. One thing we would like to rule out is a network configuration issue. You mention you are on a wired connection,  I assume this is wired directly to your router, correct? Would it be possible to connect your console directly to your modem, bypassing the router completely. This would just be for testing purposes, as it will help us isolate the issue. Thank you, I look forward to your response. :)

    Emily - Program Manager @ Xbox, Xbox One Preview Program

    • Level   1

    Thanks for replying... yes, I was wired directly to the router.  I can try wiring directly to the modem later today and will post what I observe.

    I will also say that after having the same problem last night, I decided to try using the wireless connection instead of the wired connection (I figured this could help isolate whether the issue could possible be a hardware issue or specific to the wired connection somehow).  Using the wireless connection resolved the issue - I was able to stay connected to XBL and stream a Netflix movie last night.  Does this information help troubleshoot?  

    I would prefer to keep it on the wired conection if possible, and if it's a hardware issue, I'd want to be able to confirm it and get it reapired on warranty.

    Thanks again!

    • Level   1

    The issue does not exist when bypassing the router.  What are next steps?  Thanks!

    • Level   1

    With UPnP on and port forwarding off, the issue seems to be resolved.  Thanks!!

    • Level   X

    Awesome! So glad to hear. Please let us know if you have any other issues, but if not - Happy Gaming! Or, maybe Happy Hulu/Netflixing! ;)

    Emily - Program Manager @ Xbox, Xbox One Preview Program