This question is answered

Problem with corrupted profile, and downloading profile from Live

  • Level   1

Hey guys I have a problem with a corrupted profile again. This is the 3rd time this has happened to me in the last month or so (after never having had this happen to me previously!)...

The new problem is that I just turned on my xbox to see that I had a corrupted profile, no big deal I thought I'll just do the same thing to fix it I've done the last 2 times. I go to delete profile only and it says "Sorry can't perform selected action" or something to that effect. So i try again and it says the same thing, BUT it did actually delete the profile off of my HDD as I discovered when I checked the storage settings.

SO I go to download profile, eneter all my info, everything goes fine until it says "Hello L3p3rm3ss14h!" and the DL bar fills up about 1/4 of the way then it says "Sorry Xbox Live profiles can't be downloaded right now. Try again later. 8007045D"

And now I have no profile on my box. I've done a network test and it says everything is fine. I've re-set my router and modem and tried again, same issue.

What's going on? Why can't I DL my profile? And WHY does this keep happening to me? Is my HDD dying, or is it something on Xbox's end?

Verified Answer
  • Some NAT problems are subtle and don't appear in the Test Xbox Live Connection test.

    Most likely there's a port blocked... ports can be blocked in your router, modem, or at your ISP. Since the Xbox 360 uses different ports than PCs & Macs use, you can't see the effect of a port blockage except on the Xbox.

    A sequential power cycle is the first step in clearing a port blockage:

    1) turn off the Xbox then

    2) unplug the power from the router

    3) unplug the power from the modem.

    4) Wait at least 30 secs then replug the modem  power.

    5) Wait 'til the light on the front of the modem  which says ONLINE, READY, CABLE or DSL is on solid (not flashing), then plug in the router. If you have a gateway instead of a modem and router, then when that light says it's ready, skip step 6.

    6) Wait until the WiFi light on the router is on; you may not use WiFi, but it's still a good indicator your router is finished booting up.

    7) Turn on the Xbox.  For more background on Ports, see whatismyipaddress.com/port

    Support: tinyurl.com/XBLnumbers or Request A Call support.xbox.com   How to get FreeLIVE j.mp/XVriY7

All Replies
    • Level   1

    Also, forgot to add this: Country/state - USA, Pennsylvania

    Modem - Arris Model # - WBM760

    Router - Netgear N600 Model # - WNDR3400

    Wired connection on an 250g Xbox Slim

    Things I have tried: UPnP is enabled, I haven't seen any NAT errors, my ISP is Comcast. I've tried unplugging my modem and router to re-set them, and had the same problems afterward

    • Level   1

    I did try your power cycle tip (I already had tried before, but I don't think I waited until the "online" light on the modem had turned on before I plugged the router back in). Then I turned the box on and checked my HDD to find that the corrupted profile was still in the HDD, even though when I went to sign in it didn't show at all. So I tried to delete it and this time it finally worked, then I re-DL'd the profile like normal.

    So, crisis averted I guess. I still would love to know why this keeps happening though, I've done literally nothing different in the last month to cause this problem to happen and keep re-occurring. Some googling seems to show a few people suggesting this has something to do with the last dashboard update, any truth to that?

    • Level   5

    Hey there L3p!
    Issues referring to error code 8007045D has to do with possible corruption on HDD and is not related to an update. The problem is, even when deleting your profile it is not completely deleted. The most known solution for this problem is to remove your HDD and download your profile to a USB memory stick. Then re-attach HDD and move your Gamertag from the USB memory stick to your storage drive.

    Unit A ₪