This question is answered
LOCKED

It appears you've found a glitch in the system

  • Level   1

This comes up when I go to manage my payment options.

 

It appears you've found a glitch in the system.

date: 7/23/2012 5:46:56 AM
code: 2E9796F3DB706E3
s:   FAMHuhlxdOgyp4mWd6CStg==
id:  c1f304cf-16ec-4c7d-bcde-15c313ca6bb6
req: efbbf9ba-8979-4108-9a3f-8d683c1ed38b
Verified Answer
  • Yeah seems like a temporary problem. I was able to access that page too.

All Replies
    • Level   2

    Greetings,

    I believe that you just encountered an error at the time you were signing up. Please follow these steps and try again>

    1. clear your browser's cookies

    2 attempt to sign up again

    Regards

    • Level   1

    Thing is, you never read my post.

    • Level   7

    Have you attempted to use another web browser or visit the Microsoft Billing site located here to edit your payment options?

    • Level   1

    Count me in with the problem. ;(

    • Level   5
    • Suggested Answer

    Hello 'Fly Guy Cev' and 'XxUnbeatableMeX'.

    I have just tried to access that area of the site, and it was successful. My opinion would be that it is a temporary glitch or error. I would leave it for a few hours and try again. If you are still unsuccessful, then first follow the advice given to you by Lollamia (Although he misread your post, his advice is still worth trying). If this does not fix the problem then follow  Hassassinade's suggestion. Download another browser temporarily, and use that. Though I am quite certain that this will be fixed shortly, this website fixes it's problems and errors very swiftly. I hope this helps.

    Take care.

    @XboxPlaydatesUK      Vote to make the forums better (Click)

  • Yeah seems like a temporary problem. I was able to access that page too.

    • Level   5

    XxUnbeatableMeX, thank you very much for coming back and letting us know, it's nice when users clarify the fixes on their end. I am glad you were able to get to where you wanted to go. Thanks again.

    @XboxPlaydatesUK      Vote to make the forums better (Click)

    • Level   1

    Sure, you're welcome.

    • Level   1
    • Suggested Answer

    I just had a user contact me with a similar problem, I had him delete cookies and browser history. When that didn't work on explorer I had him switch to firefox, the problem seemed to have been solved.  Thanks to my fellow ambassadors for the solutions.