This question has suggested answer(s)

Borderlands 2 Compatibility pack not working.

  • Level   1

I have BL2 and I can't get it to work online at all.

When on the dashboard, it says I have the 392 MB compatibility pack downloaded but when I get on BL2, it says I need to download it. this video here shows the exact problem I am having.

I tried clearing my cache 3 times, deleting the compat. pack and re-downloading(this was shown in the video but just to make sure whoever reads this know, even when I delete the compat. pack from my HD, it still downloads in less than 15s or so. Like it still has it on my HD but it's just redoing it or something.  It doesn't go 1%... 2%.... 3%... just 1%.... 99%... 100.) , I also tried moving everything on my HD for BL2 to a flashdrive.

Nothing I can find online has worked at all. 

This is my first time on here so if this post is in the wrong place please excuse me.

Any help is appreciated, thanks.

All Replies
    • Level   2
    • Suggested Answer

    Try this...  delete it from your hard drive, clear the cache.  Once that's complete boot the game up...  instead of downloading it from the compatibility pack option from the main menu, go to downloadable content and choose the compatibility pack from there.  Let me know if that works for you?

    The quieter you become, the more you are able to hear.

    • Level   1

    It did not.  Thanks for trying tho.  

    • Level   1

    have you fixed it i have same problem

    • Level   1

    @Brilliant Joey Didnt work for me either...

    • Level   2

    I am also having the same problem and I am a season pass holder too.

    Any solution yet?

    • Level   1

    The 2K support team told me to

    1) delete all compatibility pack updates

    2) clear your cache

    3) turn off Xbox

    4) turn on the Xbox

    5) load the game

    5) download the update

    6) re download the compatibility pack

    I did it this and it worked the first time. They did say at the end of the email that if this strategy didn't work, then do it again until it works...Hope this helps. :D

    • Level   1

    Thank u so much DomeClapper it worked the first time for me 2 :D

    • Level   1

    DomeClappers solution worked for me too.


    • Level   1

    DomeClapper, awesome job passing along this information. It's taking me for a very long time but I'm not in the States currently and my connection is averaging about 200kb/s.... but it's coming along finally.