This question is answered

Assassin's Creed Revelations won't load/install

  • Level   1

Hopefully someone out there will be able to help me with this as it's starting to vex me greatly.

So, i stick my brand new copy of ACR in and the damn thing won't play. The Xbox is recognises that the game is in as it comes up on the dashboard with "play AC Revelations". However,as soon as you click to play the screen just loads to black and stays that way...i actually have to turn to Xbox off & on as it won't just let me jump back to the dashboard. I've tried installing it but everytime it gets to 53% and stops saying the disc is faulty.

So,i return the disc and get another new shiny one only for the same thing to happen (even down to the 53% mark). Thinking it might be the actually Xbox i've tried every single game i have and they all work fine.

So whats the pickle?

Verified Answer
    • Level   1
    • Verified Answer
    • Verified by

    Try clearing your console Cache

    1) Go to the "My Xbox" menu in the dashboard.

    2) Scroll over to "System Settings" and press the X button.

    3) Select "Memory" from the "System Settings" menu.

    4) Scroll down to your storage device and then press Y.

    5) Select "Clear System Cache".

All Replies
    • Level   1

    Hey! It works! Kinda. Ok,so it still won't let me play it right off the bat from the dashboard but it did let me install it and play it from there. Good enough for me!

    Thanks a bunch for that.

    • Level   1

    Always happy to help :)

    • Level   1

    Hi. having same problem but dont know how to install it. cant you help.

    • Level   X

    Hey Cyber, what happens when you try and install the game? Did you already try the suggestions listed in this thread?

    Mister Fitzer - Xbox Community Engagement

    • Level   1

    when i try and install disc it gets to 49% and says can't read disc. it may be scratched or dirty but its not as its a brand new game and i have checked it. don't what else to do. really winding me up.

    • Level   X

    Hey Cyber, what you'll want to do in this case is go into storage and see if there are any corrupted or incomplete files there. To do so, press the guide button, then go  settings > system settings > storage > all devices > games and apps. Once there, please delete any and all files relating to that game (with the sole exception of your save files), as well as any incomplete or corrupted files (which should show up with an exclamation point on them). After that, please clear the cache, and then try re-installing the game. :-) Let me know how it goes!

    Mister Fitzer - Xbox Community Engagement

    • Level   1

    ok dont that. tryed istallng again and its still doing the same thing.

    • Level   1

    I'm having the exact same problem, tried 2 brand new discs and it just won't install, I've used a disc drive cleaner and it rectified why the other game wouldn't install, but it's just Assassin's Creed: Revelations that won't install and when I try playing it, it freezes up.

    • Level   S

    Hey there DwarfehKitteh!

    Please go ahead and make a new thread detailing your issue and any steps you've taken so far to fix it. That is how these forums work best as it lets us tailor our support to your specific issue. ^_^

    Xbox Forum & Reddit Support || Monday - Friday 9:00am - 5:00pm PT
    How to Use the Forums || Forum Guidelines
    Do you have an idea to improve Xbox for everyone? Share it with us at Xbox Feedback!