This question has suggested answer(s)

Error Downloadable content has changed: storage device has been removed

  • Level   1


I'd say 1 out of every 3 times I play Black Ops II I am getting kicked out of the game and getting this message.  It's not my disk, the XBox is only like 2-3 years old, and it's not just with the downloaded revolution maps.  

I've read the forums and it said to delete my cache.  Well, thats great except my cache only had 128kb on it and deleting it did nothing.  I tried cleaning the disk with a soft cloth, nothing.  I don't want to download the entire game to the HDD since I already ran out of space on the hard drive once and was forced to buy an XBox flash disk.  I've read through all the forums and I'm hearing everything from it being a problem with the disk to the hard drive failing on the XBox.  And it seems that every suggestion offered works for one person but nobody else.  I don't want to buy a new disk and have the issue be my hard drive.  And I don't want to send the XBox in for repair and have them tell me it's the disk or connection.  I can't hardwire it, I have a strong connection.  The game isn't damaged.  2/3 times it works fine...then as you enter a game map the third screen...Error message.  No "green screen".

My memory is fairly empty..only about 1/4 of the 4GB is being used.  When will this be fixed?  Can I call someone?  Can I get some service?  

All Replies
    • Level   5
    • Suggested Answer

    Have you checked the connection of your hdd to the xbox itself, it may be loose, dirty or bent....?


    please do this by,

    Xbox 360 S console

    The Xbox 360 S 250 gigabyte (GB) console has an internal hard drive, which can be removed and replaced. The Xbox 360 S 4 GB console has internal flash memory, which is not removable. The internal hard drive can be purchased separately.

    Insert a hard drive in the Xbox 360 S console

    1. Turn off the console.
    2. Position the console horizontally.
    3. On the right side of the console, locate the hard drive cover release near the back of the console.
    4. Slide the release toward the front of the console, while pulling the hard drive door open.
    1. Insert the hard drive into the slot, and press firmly until you hear it click.
    1. Replace the hard disk drive cover.
    2. Turn on the console.

    Remove a hard drive from an Xbox 360 S console

    1. Turn off the console.
    2. Position the console horizontally.
    3. On the right side of the console, locate the hard drive cover release. It is close to the back of the console.
    4. Slide the release toward the front of the console, while pulling the hard drive door open.
    1. Pull the tab to remove the hard drive.
    1. Replace the hard drive cover before turning the console back on.


    Original Xbox 360 console

    Note When you handle your Xbox 360 hard drive, avoid touching the hard disk drive bay contacts or the hard disk drive connector with your fingers or metal objects.

    Attach a hard drive to the original Xbox 360 console
    1. Turn off the console.
    2. Position the back of the hard drive against the back of the hard drive bay. 

    Note If your console did not previously have a hard drive, you will need to remove the hard drive bay cover before attaching a hard drive.

    1. Push the front end of the hard drive down until it clicks in place.

    Remove a hard drive from the original Xbox 360 console

    1. Turn off the console.
    2. Locate the hard drive on the top of the console (or on the left side, depending on how the console is oriented).

    Note Not all Xbox 360 consoles include a hard drive.

    1. Press the release button on the hard drive.
    1. Lift the hard drive away from the console.

    Make sure your console recognizes the hard drive

    After attaching the hard drive, make sure your console recognizes it. Here’s how:

    1. Press the Guide button on your controller, go to Settings, and select System Settings.
    2. Select Storage or Memory.
    3. Make sure Hard Drive appears in the list of Storage Devices. If it does not, try removing and reattaching the hard drive to the console.




    If the connections are bent or damaged you may need to purchase a new hard drive.

    • Level   5

    lol I just realized you said you have a 4g, sorry disregard my last post. as you have a 4g and said you bought an memory stick, Is this happening when you are trying to access content stored on the USB?

    If so it may be possible that your USB has unformatted itself from the format needed to be used with xbox.

    for solutions to that check this link here >

    Good luck and let me know how it goes.  -Listed

    • Level   1

    No, I think you're misunderstanding.  I DID buy a flash card for the XBox because the Black Ops game needed so much space that there was no room for any other I moved games less played to the XBox flash drive I bought.  The storage on the actual XBox (4GB) is now devoted to just Black Ops and a few kids games...not even using 1/4 of the capacity of the 4GB.

    The formatting is a problem in and of itself...where you buy an "official XBox flash drive so it'll work optimally and it gives you the same warning as regular flash drives that it may not be fast enough for the XBox...but thats another issue since I'm not using that for Black Ops II...where I'm having the problem.

    I don't want to buy additional hard drives or transfer my content to the flash drive.  I mean, the 4GB XBox should work.  If it doesn't, then Microsoft needs to fix it or they can buy me a new hard drive.  I just have a feeling if I send my XBox in for repair:

    A) They are gonna want to charge me $$$ to fix a problem I didn't even cause.

    B) They are going to tell me its the Treyarch/Activision game, not the console.

    And I doubt Treyarch or Activision is going to send me a new disk...and even if they do it'll likely have the same problems.  And I'm certainly not buying another game just because Activision/Treyarch can't make a game that lasts 3 months.

    • Level   1

    Wow...still no answer...problem just as bad if not worse.  Is it my XBox?  If so, where can I send it to fix it?  Is it the game?  If so, what is the status from Activision and/or Treyarch?

    I'm one of THOUSANDS of people having this what point are we going to get some answers?

    • Level   1

    I have the exact same problem u have. It's just been recently that this occured. Thought it was just me cause all my friends sound puzzled when I tell em about it.

    • Level   1

    It is NOT just you.  I googled the problem and its happening to a LOT of people!!

    I'm not sure if it's an XBox issue or a Treyarch/Activision issue...but until its resolved I'm definitely not lining up for anymore Activision/Treyarch games or the new XBox console.  : (

    Here are some other issues that hopefully will help solve this mystery....all of these things tend to happen before getting the error:

    1) Some of the content doesn't show up.  We're talking about avatars or icons.  In the combat record, you might be missing your screenshot or player cards.  You will see that "Treyarch Symbol" as if it's trying to load those but not being successful.

    2) You'll have trouble accessing your videos or editing your player card.  Again, "Treyarch symbol" as if it's loading those items but it can't.

    3) After you finish a game, you can usually tell when it's going to crash at the next game...because you kill medals won't load in the after game summary.  Normally those medals show up...but in the game BEFORE you crash...those will show up as "Treyarch Symbols" as if they are trying to load but can't.

    4) The only issue I've found when you're actually PLAYING the the crosshairs on sniper rifles.  When the game starts messing up...your sniper rifle crosshairs won't show up when you're aiming.  If you don't use sniper rifles...wouldn't notice that.  You can still aim and fire the rifle...but no crosshairs.

    Given the gameplay issue...I think it might be more game than XBox.  It seems memory/hard drive related...which leads me to think its an XBox issue.  And most of the time the game itself plays fine. other games seem to play fine on the XBox...if it was a faulty processer or memory...wouldn't my other games show signs?  

    Now, the other game I usually play I save to a flash it "could" be the XBox internal memory.  But at this point, my best guess is that it is an activation/treyarch problem with the game and how it saves information to the XBox.  I'm nowhere near a software guru...but it seems like the game stores much of its information in a sort of transitional state on the XBox.  It can't store anything on the CD...thats just gameplay and maps.  And the server is just to host the games.  So much of the gameplay is constantly being stored and read from the storage destination on the XBox.  And I think thats where the problem is.  Either the XBox internal memory is having issues storing and making that information available...AND/OR...the game is faulty and having trouble retrieving that information.  It's as if the game is "forgetting" where it put the information.

    Now is that the game?  Or is the XBox memory dirty or poorly connected or improperly formatted/designed??  Who knows?  But this is a problem that is going to continue to get worse and worse.  It started happening to me last week and now a week later I'm getting the green screen every 3-4 games...I got gameplay issues..and it's not "infrequent"...its a regular occurrence.

    • Level   1

    And another problem that will soon to be floating around the forums....certain maps going "rave" where the map shows up as neon green and black and you can't see your gun....just started happening to me....heard other people saying its happening to them as well....hope activation is working on some patches!!

    • Level   1


    • Level   1

    YES this is happening to me to its pissing me off my screen is all green when the map is loading and then after a few seconds it just boots me off and says downloadable content has been changed storage device has been removed! Can someone actually help me!

    • Level   S

    Hi Dope! If you could go ahead and create your own thread, detailing your issue a bit more, as well as any troubleshooting steps you have tried, we will get right on it. Thanks!

    • Level   1

    Same thing started happening to me yesterday on Black Ops 2.  It doesn't seem to be a problem until my 2nd match is about to start.  When the map page is loading up it will cut out and say it.

    • Level   1

    I tried the above advice, rented it from red box, downloaded it to the hard drive, put my disk back in and it works flawless once again.  Thank you!