This question has suggested answer(s)

Unable to connect to a WPA2 Network

  • Level   1



I've recently bought a new XBOX 360 S and using the internal WIFI I'm trying to connect to my wireless home network, which has WPA2(AES) encryption but the connection fails while it is attempting to access my network (before the test checks if there is an internet connection).


I've tried a couple of things:

1. Tried connecting as usual, entered the password - failed.

2. Tried removing the MAC filtering and then tried to connect - failed.

3. Removed the network encryption entirely (unprotected network) - worked! So I've updated the console with latest updates from XBOX Live and then re-applied the network security - again, failed.

4. Went through the XBOX network troubleshooting guides (Tried resetting the network definitions, resetting the router, making sure dhcp is enabled, etc) - failed.


I'm using an edimax br-6424N router - is it possible the the router is the one causing the problem?


Any ideas?


Thanks in advance,



All Replies
    • Level   1

    Hello Tzahi,

    Unfortunately the xbox 360 wireless does not support WPA2-AES, it does however support WPA with AES  that uses the same "fancy" encryption technique as WPA2, but leaves out some of the comercial authentication methods supported by WPA2. Since home users are mostly using Pre-Shared Keys (PSK) comercial authentication methods don't matter.

    Thus, WPA with AES is the way to go for the most secure Xbox 360 compatible wireless network.

    • Level   7


    I'm not quite familiar with your specific brand of router so it may be the culprit as the XBOX Support documentation states the following:

    "Use WPA2 if possible: The best wireless encryption to use with your Xbox 360 console is WPA2 with AES encryption."


    I currently use WPA2-AES and when I can't use an Ethernet cable and connect wirelessly it works flawlessly. So, going off of what you've already tried I'm assuming it's a problem with that brand of router that's causing the issue with the WPA2-AES.

    You could however try a different wireless security setting as you've said yourself it works without any sort of wireless security on and give that a go. Or, you can also check to see if the manufacturer of the router has a firmware update that might fix the issue that your encountering. 

    Twitch Partnerships, Development | Twitter: @BackwardsNinja

    • Level   1

    Thank you both for the answers!

    I've also seen the 'Use WPA2 if possible' paragraph and also I've searched the internet and could not found any documentation that states that the internal wi-fi doesn't support WPA2.

    DTDanthebest01, what makes you think that WPA2 is not supported?

    • Level   7


    Your information is incorrect. The Xbox does support WPA2 AES

    @Harvester, what version of firmware is the edimax using can you post it up?

    • Level   1

    @Shad0wmanUK - The edimax firmware version is V1.21

    • Level   7

    I'm not sure what part of the world you are from but in the UK there is a  more up to date version of firmware

    Or if you are outside the UK 1.21 seems to be the latest

    If you are using the latest firmware then I'm afraid it sounds like an incompatibility issue that you should report to Edimax, please try all of the available security options on your router hopefully one will work and Edimax can bring out a fix in firmware.

    • Level   7

    After your tried all options please let us know if WPA works for you or if none of the security options work, it will help others with similar problems with that router


    • Level   1

    To those who say I'm wrong, every xbox wireless adapter etc. that I have bought has had a clause saying WPA2 is not supported/

    • Level   5

    I would suggest Resetting the Factory (Network) Settings.

    Tap on the silver Guide button again, go two clicks to the right, choose Settings, System Settings, Network Settings, then choose your connection ( the SSID of your WiFi connection ), then Configure Network.

    Copy down the settings for IP (auto/manual, IP address, subnet mask and gateway) as well as DNS (auto/manual, primary DNS server, secondary DNS server), then

    go one click right to Additional settings. If anything is _not_ blank or Not Set, make a note of those settings as well, then go to the bottom and choose

    Restore to Factory Defaults and confirm. Then power down the console, wait 8 secs or more, power back up and reconnect.

    Support: or Request A Call   How to get FreeLIVE

    • Level   1

    @Vibroplex - Resetting to factory settings didn't work (tried it a couple of times).

    @DTDanthebest01 - Just to be clear, I'm attempting to connect using the built-in XBOX network wireless adapter, not using an external WI-FI adapter.

    @Shad0wmanUK - I am outside of the UK, 1.21 is the latest I could find.

    After changing the network security to WPA(TKIP) I did manage to connect, but WPA2 still doesn't work.

    • Level   5

    Well, not every router completely complies with the WPA2 specifications. WPA is still far, far better than WEP, both in security as well as speed.

    Support: or Request A Call   How to get FreeLIVE

    • Level   7

    Thanks for letting us know. WPA(TKIP) is fine much better than the very weak WEP.

    If you get time you should raise a ticket with Edimax support to let them know about the issue, this type of issue can be fixed in firmware usually but unless they are informed about the problem they won't be able to work on it.

    • Level   1

    Update: Talked to microsoft online XBOX support - still didn't help.

    They did say that there are some routers that can only use WPA with XBOX.

    Also, my router is not in the supported hardware list (so are all of edimax routers) so they said that the router could be incompatible.

    • Level   7

    Its certainly a router problem, you'd be better off reporting it to Edimax

    • Level   2

    Try using a dual band n router from Netgear. I have one and it works great