This question has suggested answer(s)

Can't connect to xboxlive/MTU

  • Level   1

Hey guys

My first post here.

I know there are lots of threads about this issue but I've done hours of google search and I still have a problem.I can't connect to xbox live(It fails in the "connecting to XBOX live" test) it gives me the "MTU error".

So I checked my MTU and it's set to 1500 which is higher than the minimum requirement,so what can I do ?

All Replies
    • Level   2

    Okay, if you’re encountering an MTU error when you run a LIVE connection test, then you’ve come to the right place. Here are a few quick things to try to get you back on LIVE! 

    Restart your network equipment

    Power down your console and network hardware
    Turn off your Xbox 360 console, and then unplug your modem and router. Wait 30 seconds before moving on to the next step.

    Re-activate your network hardware
    Plug the modem back in, and be sure to give it at least a full minute to come back online. When it’s up to speed, do the same with your router, and repeat this step for any additional piece of network hardware you ‘re using. When all of your network hardware is running, turn on your console.

    Run a LIVE connection test
    Go to the ‘My Xbox’ channel in the dashboard (the dashboard is the main menu in your console), selecting ‘System Settings’ on the far right, and then ‘Network Settings.’ Select the appropriate network (wired or wireless), and then select ‘Test Xbox LIVE Connection.’

    If you still receive a NAT error, try the next step.

    Improve your wireless connection

    If you’re on a wireless connection, there are a few things to consider for improving your connection. If you’re not on a wireless connection, you can skip ahead to the next section.

    Place the router or gateway in a better position
    Some things to consider when you’re placing your router are the position of the device and its position relative to the console. Make sure your router isn’t on the floor, near any large metal objects (such as cabinets) or any other wireless devices, namely 2.4 gigahertz band devices.

    Also, try moving the router closer to the console, and make sure that there are no obstructions between the router and the console if possible, such as large pieces of furniture, or walls.

    Change/boost your signal
    You can try changing the channel on which your router or gateway broadcasts, as well as switch signal bands, if you’re on a dual-band router (for instructions on how to do so on your particular router, be sure to check your hardware manual, or check the manufacturer’s website).

    If neither of those do the trick, you may want to consider placing a wireless repeater between your console and router if there is a large distance between them. Alternatively, if you’re using the Xbox 360 S, you may want to try an external wireless adapter, to boost the signal strength.

    Simplify your setup

    Remove other connections
    Unplug everything from your router besides the cables going to your router and modem (or if you’re on a wireless network, turn off all other wireless devices). Your Xbox 360 should be the only thing connected to the router.

    Run a LIVE connection test
    Go to the ‘My Xbox’ channel in the dashboard, selecting ‘System Settings,’ and then ‘Network Settings.’ Select the appropriate network (wired or wireless), and then select ‘Test Xbox LIVE Connection.’

    If you don’t receive an MTU error after simplifying your setup, it suggests your hardware is having issues managing multiple connections. These next steps should resolve that issue.

    Change your MTU setting

    Log into your router settingsBr> Okay, we’re almost there! Start your web browser, and in the address bar, type the default IP address for your router or gateway, and press ENTER (be sure to check your hardware’s manual, or the manufacturer’s website for this info). IP addresses for popular router and gateway manufacturers are listed below:

    Lynksys by Cisco:
    NETGEAR: or

    Enter the user name and password for your router, and then press okay. If you do not know the user name or password, be sure to refer to your hardware manual, or the manufacturer’s website.

    Change your MTU setting to at least 1364
    If you’re unsure how to check or change your MTU setting within your router settings, check your hardware manual or the manufacturer’s website. If you change the MTU setting, be sure to run another LIVE connection test. If you still encounter a NAT error, move on to the next step.

    Open network ports

    For the best results with Xbox LIVE, you’ll want to ensure the following ports are open:

    Port 88 (UDP)
    Port 3074 (UDP & TCP)
    Port 53 (UDP & TCP)
    and Port 80 (TCP)

    For detailed instructions on how to open your network ports, be sure to check out Open Network Ports in this sticky. If you still encounter an MTU error after opening your ports, please move on to the next step.

    Determine if your router or gateway need replacing Okay, you’ve tried all the steps, and you’re still getting MTU errors. At this point we’ll want to check that your router or gateway is compatible with Xbox LIVE.

    Try a direct modem connection
    For right now, use an ethernet cord to hook your Xbox 360 console to your modem, bypassing the router entirely. Run a LIVE connection test, as described earlier in this guide. If you no longer encounter the MTU issue, it indicates your router is not compatible.

    Check for hardware compatibility
    If a direct modem connection resolves the MTU error, then you’ll want to consider purchasing a new router or gateway. This page has an extensive list of supported hardware.

    I’m still getting an MTU error. What do I do now?

    You may want to give your Internet Service provider a call, to see if they have a resolution for the error on their end. Also, feel free to make a post in the forums, though please be sure to check the questions at the bottom of this page, to better help us help you!

    Subject Matter Expert for Xbox LIVE!

    • Level   1

    Forgot to say that I've tried all that but it didn't help :(

    Also called the ISP but they couldn't help

    • Level   1

    The strange thing is that my MTU is actually higher than what's required...

    • Level   S

    Can you try resetting your router to factory defaults and then set it back up. Also, if you have another router at home or one you can borrow, try using that instead to see if you get a different result. Let me know, thanks!

    Xbox Community Ambassadors Team
    Join the community!

    • Level   1

    Yep I've tried the factory default settings but it didn't help.

    Will try with another modem tomorrow and will report back

    • Level   1

    OK,so tried with another modem but no luck(Same error)

    • Level   7


    Please read:-

    And post back your details in full (the bits that are in bold on that post) so that people may help

    If you are wireless can you also state whether you are using the white or black external adapter or the Xbox 360S Internal adapter


    • Level   2

    MTU = Maximum transmission unit = the amount of information being delivered in any one packet.

    If you have an MTU issue try turning off your firewall

    Subject Matter Expert for Xbox LIVE!

    • Level   1

    What Country/State/Province do you live in?


    Modem brand & model number

    Zyxel P660HWT1 v2

    Network Connection Type: Wireless/Wired

    Wired(but tested with wireless too)

    If Wireless, what type of encryption are you using?


    Is UPnP Enabled? Yes/no/Unknown

    It's disabled but I enabled it to test and same result....

    Is NAT Type Open?

    Not sure how to check it

    After you run "Test Xbox LIVE connection" and click on "More info", what is the exact message shown on screen?

    Minimum MTU error.

    And I tested with firewall turned off but it didn't help

    • Level   7
    • Suggested Answer


    Try following this guide:-

    • Level   1

    Didn't help :(

    • Level   5

    Run a MTU ping test to determine the optimal MTU size for your connection.

    For Windows: Go to Start and select Run

    Type in cmd

    In the DOS prompt, type in ping -f -l 1492 (note the space between -f -l)

    If the results indicate that the packet needs to to be fragment then lower the size with -10 from 1492 until you have a packet that dont fragment.

    Try this and come back with the results.

    • Level   7

    Who is your Internet Service Provider? Do you have the latest version of firmware for your router?

    • Level   1


    It gave me this: Packet needs to be fragmented but DF set.


    Virgin and yes

    • Level   7

    So you are obviously on Virgin ADSL then and not cable.

    So you've tried port forwarding and UPnP and it hasn't helped, has this ever worked on your set-up?