This question is answered

Update Failed 3151-0000-0080-0300-8007-2751

  • Level   1

Turned the dang thing on and went to test my connection.  It got all the way to the link between my internet and XBL to receive a popup saying I need an update.  Try to install the update and I get that status code.  Apparently I need the update to get onto XBL but I also need XBL to receive the update?  Now I'm pissed.

Verified Answer
    • Level   7
    • Verified Answer
    • Verified by

    The error code ending in C000-0001 means that you will need to contact phone support for assistance. In the future if you require assistance with any sort of issue please make a new thread instead of bringing back an old thread, it keeps  other people from getting responses that are just towards you.

    Twitch Partnerships, Development | Twitter: @BackwardsNinja

All Replies
    • Level   V

    Update failure

    When the xbox tells you an update is needed, but the update will not complete properly.

    There are four reasons this can happen.

    1. There are some corrupted files on your harddrive or your harddrive does not have enough space left.


    2. There are some previous downloads stuck in your download queue.  


    3. There are some settings in  your router that are blocking the download.


    4. Your account is not in good standing.

    First try to fix number 1:    

    Look at the contents of your harddrive and delete any files marked as corrupt.   Then whether you find any or not,  run the hard drive maintenance routine.

    Harddrive cache clearing.  If there is not enough space, delete some demos or other files you no longer need.

    try clearing the Xbox 360 Hard Drive cache.

    With the Xbox 360 Hard Drive attached to the console, follow these steps:

    a.  Locate the System section of the Xbox 360 Dashboard.  

    b.  Select Memory, select Hard Drive, and then press Y to view the device options screen.

    c. Select the Clear Cache option

    Additional cache clearing

    It is possible, that the console has a corrupt update download cache.

    You can clear any failed updates by turning off your console, pressing and holding the small synch button next to the Memory Unit slots, and then turning on the console while still keeping the synch button pressed.

    This will clear the update cache, and force the Xbox to redownload any failed update again.

    To fix number 2:

    Clear your download queue on you can always restart any downloads later.

    Fix number 3:

    If that does not fix the issue.  You will need to look at your router.   If you have a separate router and separate modem,   then try connecting your xbox directly to your modem;  just to get the updates.    Once you have the updates, you can connect it back to your router.    You may want to investigate the proper settings for your router to work fully on Xbox Live.

    Fix number 4:

    If connecting to the modem still does not fix the issue, check your account status for expired credit cards or other issues.

    If all else fails:

    You can also check the instructions at this site for other ways to install the update


    Live long. Love life.

    • Level   1

    I tried most of the advice and its still not working! Gonna try updating with disc, but still think I'll be dead in the water!

    • Level   X

    Hey - if you're still having issues with the update, try connecting directly to your modem with an ethernet cable. That should fix most issues. :)

    Emily - Program Manager @ Xbox, Xbox One Preview Program

    • Level   1
    • Suggested Answer

    I experienced the same problem after changing DNS and security Settings on my Router. I tried the suggested actions already posted here and nothing changed.

    Strange as it may sound, I reset the Router back to Default Configuration and the Xbox was mighty happy and started to download again.

    *Caution* BEFORE you reset your Router back to Default Configuration, spend 2 seconds saving the current configuration just INCASE it doesnt fix your xbox problem.

    • Level   1

    None of this is working at all....... about to flip out

    • Level   1

    Had same issue. Deleting profiles allowed the updates to take and resolved the issue.

    • Level   1

    same problem, brand new 250gb xbox did this to me, my elite was running fine literally 5 minutes ago.

    i deleted the guest profile and cleared the cache (even though it had never been used so should have had no history) and then it worked, performed the updates and recovered my gamertag. very strange though.

    • Level   1

    I deleted the cache and that didn't work, so then I deleted some extra profiles and that seemed to do the trick.

    • Level   1

    I had to format the HDD TO UPDATE....F***

    • Level   3

    deleteing your profile and erasing your harddrive makes no difference. do not do those steps.

    It has yet to be proven that intelligence has any survival value. - Authur C. Clarke
    • Level   1

    16 feb update gave Slim users problems,like me.i installed it thro usb,which has fat32 file type thingy, installed it,after that,i couldnt look at my friends list,it said:some xbox live content is unavailable temporarily,it will appear automatically when available.something like that.i also cant play live,or see my account,where i would do smthn to repair this.

    • Level   1

    I've Had The Same problem, i tried almost everything except formatting the hdd but thats the last resort. is there any way to fix this? every time i try to update it will jump to a certain point then just stop and an error code will pop up, then i hit ok and the system restarts with some bullsh*t . i tried connecting with ethernet,wireless and using a cd and a usb thumb drive but it still goes only a certain way and stops again. any other suggestions?

    • Level   S

    Greetings, DeadReckoning23. Can you please create a new thread by clicking the link here: ? Please be sure to explain your situation in full including the troubleshooting steps you have tried so far? This will enable us to provide you with the best support possible.

    I would encourage anyone else who needs assistance to do the same.

    In the future, please be mindful of the original post date of the thread. This will avoid the inadvertent bumping of months old threads. Thank you!

    How to use the forums
    Retired Support Agent - No PMs please!

    • Level   1
    • Suggested Answer

    The error code you put here is a networking error code. It is not a problem with your Xbox but with your internet connection. I had this happen to me while updating Netflix a few days ago and i just waited a day and it was fine because my router has times when its slow and times when its fast. I have a few suggestions

    1. Just wait it out. Give it a day. Maybe try to stay off your computer and then try a few days later and test it.

    2. Move your Xbox. If Your Xbox is in a basement or maybe hidden away in something just bring it out/up for a while and see what happens.

    3. Get a better internet connection or maybe call your internet company and have them make sure your internet is fine and they could come check it for you as well

    Xbox Live Ambassador | Questions? Tweet me @Alexcappel or Message me on Xbox Live, Gamertag: Appelcappel

    • Level   1

    i have an error 22fb-397f-b600-0402-c000-0001 can some one help mi out.