This question has suggested answer(s)

Fable 3 Problems with joining other friends game Vice Versa

  • Level   1

So I recently Got Fable 3

When I try to join my friends Game session it says


" You cannot join this game because you do not have the same downloadable content as the host"


So he then sends me the invite to join my session which almost worked , because I got a message from him asking to and as the xbox tried to establish it was interrupted with the same message

" You cannot join this game because you do not have the same downloadable content as the host"


Can anyone help me as to tell me whats wrong? or how I can proceed to fixing it so i can have the same downloadable content

P.s does the Downloadable content mean xbox updates?

Yes I have recently downloaded Fable 3 Free content onto the console


1. Bought this game off ebay less than a week ago

2. This is the cover of the game


I do wonder  my game cover doesnt look like this one

that says "Xbox live"

could that be a problem? sorry I know it sounds stupid.. I'm just a noobie XD



All Replies
    • Level   1

    oh another thing

    I changed my settings on Fable 3 last night  , the ones that allow random people to come into the game without permission , and some stranger managed to come into my game , so it must me we have compatible content... I just wish I knew what it was

    • Level   X

    It sounds like the friends you're trying to play with may have DLC for the game that you do not (or vice versa). Be sure to check with them to see if they have purchased any additional content with the game, or if their copy came with additional content.

    Mister Fitzer - Xbox Community Engagement

    • Level   1

    i have the same problem only my friend has all the same dlc as me but it says the network connection is bad and i check it and its in 100% working order what should i do to fix this??

    • Level   S

    Austin: So you have a completely different problem. Check out our Communication ( and NAT ( stickies to get started here.

    Xbox Community Ambassadors Team
    Join the community!

    • Level   1

    I have the same problem did you ever figure out why it says your content is different?

    • Level   2
    • Suggested Answer

    Its either that he has downloaded the Traitors Keep or Understone DLC and you haven't, or he has downloaded the free extra content on the marketplace such as the soldier outfit, yule hat etc. and you haven't. go to the marketplace and download all of the free extras on there, the yule hat, soldier outfit, weapons pack etc, then try it. if it still doesnt work, then I would guess he has Traitors keep or Understone.

    Yt: NINJ4G4MINGCommunity

    Twitch: NINJ4_G4MING

    Fb: Ninj4 G4ming

    • Level   S

    Hey guys! If you're having an issue playing Fable III or another game can I have you create your own thread detailing the issue you're experiencing! This will help us provide you better support!

    • Level   1

    Same problem

    • Level   S

    Hey there AWESOMEHURLEY7!  I would start with deleting/redownloading the game and DLC.  If that doesn't help, please post a fresh thread and we'll be happy to take a look for you!