This question is answered

My Xbox won't connect to Xbox Live, IP address error

  • Level   1

I have tried all of the troubleshooting options for and IP adress error on my Xbox console as well as at the support wizard:

Nothing that I have tried works. I have tried resetting the Xbox and the router and modem. I have also tried with the wireless and with an ethernet cable. I always test my Xbox Live connection after each step. It always tries to connect for a few seconds, then stops before it connects to the router and displays "IP Address Error." I am 90% sure it is not the router because I have some other devices connected to it (wired and wireless). It had never done this before I  recently updated it from the old dashboard. I updated it using a wired ethernet connection. Right after the update, it was connected to Xbox Live through the ethernet connection. After, I disconnected it and moved it. I tried to connect it using a black wireless adapter, but it did not work. Here is the info:

  1. USA, Washington
  2. Comcast SB5100 SURFboard Cable Modem
  3. Netgear Wireless-N 150 Router WNR1000 v2
  4. Black external wireless adapter
  5. I have tried: 
    • Restarting the Xbox
    • Restarting the router and modem
    • Manually inputting an IP adress with Subnet Mask and Default Gateway
    • Changing my WiFi network password
    • Checking my inputted WiFi network password

6. UPnP is enabled, although I do not know what it is

7. Unknown

8. Error Codes: "IP address error"

9. Comcast

Verified Answer
    • Level   1
    • Verified Answer
    • Verified by

    Try going to your router and resetting all to factory defaults. And don't forget to reset up your Wi-Fi. And while your router is doing that reset the network settings on the Xbox back to factory defaults as well. Let me know your results.

All Replies
    • Level   7


    Can you run the Xbox live connection test and post up the error codes it comes up with when you press Y?

    So concentrating on just using wired for now, can you reset your Xbox network settings to factory defaults (and then leave the Xbox settings alone) and try to connect wired again to the router.

    If that still fails on ip address failed can you connect the Xbox directly to the Cable modem. Power off the modem, power off the Xbox. Power up the modem and wait 2mins, then power up the Xbox and try to connect.

    Let us know the results and when you want to connect your router back up to the modem just power the modem off first

    • Level   3
    • Suggested Answer

    Try going to the following on your xbox

    1. network settings

    2. disconnect

    3. when disconnect click configure network

    4. reset connection to default

    5. reboot console

    6. connect again

    7. problem may or may not be fixed

    • Level   1

    I tried everything once again, and just gave up on it and went to sleep. I tried it again in the morning, and it magically worked. I have no idea what I did to get it to work, and I haven't had any problems with it since.

    • Level   7

    :) Good stuff

    • Level   1

    hi their,ive bin getting difficulties to sign into xbox live,im already member to xbox live gold,also on sky app,whats stopping me of getting anywhere into signing in my profile is,i need ip adress and wpa nextwork code,please help me from leanne kind reguards

    • Level   7


    Could you please start your own post, this one has been solved


    • Level   1

    my Xbox live do-sent want to connect i don't know what is a IP:adrees

    • Level   1

    im having the same xbox 360 dont read the ip adress.

    • Level   5

    Greetings cindy sarai!

    Can you please create a new thread and detailing out your situation for us.

    To make it easier for us to understand your network set up and your networking equipment, please read: START HERE for connection troubleshooting! And post back in full detail (the bits in bold). Be sure to include any troubleshooting steps you have tried so far. This will allow us to give you the very best support possible.

    Thank you!