This question is answered

NAT not working???????????

  • Level   1

Guys i'm mad!!!!!!!!! I always connect directly to my motorola surfboard sb6121 (moddem) and i enabled UPnP and i port forwarded all the ones the support page and DMZ it, and I still have a strict NAT. I set my IP (on my Xbox) to manual and put the right settings (same with everything else) but it still wont get open NAT. I have tried wired and wireless connection, but no difference. I DO NOT WANT TO BUY A NEW MODDEM/ROUTER!!! I just want to play Halo with my cousins.

Verified Answer
    • Level   7
    • Verified Answer
    • Verified by

    Depends what its role in the network is :) it might stop everything working if you do that

All Replies
    • Level   1

    So, UPNP won't work with a static ip address.... you will need to have a automatic ip for upnp to work.

    as for portfowarding and dmz, you need to choose one or the other, best would be to DMZ to your mac address.

    • Level   7


    The SB6121 is just a bog standard cable modem m it has no UPnP settings or DMZ

    Are you connected to a router that connects to the modem? I don't understand how you can have NAT issues if you are connected directly to that model of modem as its just a standard modem

    • Level   2
    • Suggested Answer

    Go to network settings, test connection.

    Select to test your PC connection, when it's done select your computer from the list and it will fix your nat type.

    Source: Experience.

    • Level   1

    so i found out that i connect to a D-Link router. The only problem. I dont know what router. Its a pain to look at because its in my garage like 10 feet high. I also dont get how using a manual (or static) IP Addess doesn't support UPnP. I also read in another forum, something about double NAT (not double Xbox) where the router allows the NAT change but the modem doesn't. i have tried both DMZ and Port Forwarding seperatly, but nothing really changed. If i plug a cable into the wall, is it going to my modem or to my router? There both high in my garage, so I can't really tell. I can enable UPnP on my D-Link but not my motorola. Also my internet provider is ComCast but my modem is motorola, so if I want a setting on the modem to be changed (know as bridging mode" or "pass through mode) do I talk to Motorola or Comcast?

    • Level   7

    "If i plug a cable into the wall, is it going to my modem or to my router? There both high in my garage, so I can't really tell."

    We can't tell you that I'm afraid it is your own cabling

    You won't be double NAT'ing it will be a config issue on the Dlink, please post up the model of Dlink

    • Level   1

    so the router model is dir-655 and Firmware Version: 1.21

    Hardware Version: A3

    so if i port forward and enable uPnP and use a autimatic ip address, i stil have a strict nat. It says its open, but it doesnt connect  to other people because of NAT. I still dont get this

    • Level   5
    • Suggested Answer

    Some NAT problems are subtle and don't appear in the Test Xbox Live Connection test.

    Most likely there's a port blocked... ports can be blocked in your router, modem, or at your ISP. Since the Xbox 360 uses different ports than PCs & Macs use, you can't see the effect of a port blockage except on the Xbox.

    A sequential power cycle is the first step in clearing a port blockage:

    1) turn off the Xbox then

    2) unplug the power from the router .

    3) unplug the power from the modem.

    4) Wait at least 30 secs then replug the modem (power.

    5) Wait 'til the light on the front of the modem which says ONLINE, READY, CABLE or DSL is on solid (not flashing), then plug in the router.

    6) Wait one minute or until the WiFi light on the router is on, whiched comes first; you may not use WiFi, but it's still a good indicator your router is finished booting up.

    7) Turn on the Xbox.  For more background on Ports, see

    Support: or Request A Call   How to get FreeLIVE

    • Level   5

    Hey there set!

    You should do a firmware update on your router. Visit: And download the latest update. Follow the instructions on how to update your router's firmware correctly.

    As stated from the previous poster's, do not use UPnP (automatically tell the router to open and close listening ports) and Port Forwarding (manually tell the router to open and close listening ports) at the same time.

    Solution 1
    Port Forwarding=Disabled

    Solution 2
    Port Forwarding=Enabled

    Post back and let us know how it goes.

    • Level   1

    so my firmware is the network was already uPnP enabled and port forwarding disabled. I tried port forwarding enabled and uPnP disabled. nothin changed. i still need help.

    • Level   7

    When you access your Dlink router status page what does the WAN/Internet ip address start with? 192 or 10 or 172

    Please post up the first 2 or three digits only

    • Level   1


    • Level   7

    Ok so that is the reason for your problem you are indeed "double NAT'ing" if your WAN / Internet ip address starts with 192. Whatever is connected to the Dlink (and then connected to the Internet) is also a router and the source of your problem. You need to find out what device is connected into the WAN port of the Dlink router

    • Level   1

    something weird happened today. so under my wan settings on my router, my IP address was 172 not 192. Dumb me. But this is why i thought it was 192. Under the WAN settings, my IP is 172, but everything connecting to the router like my Xbox or laptop is 192? this is confusing. in the end my router is 172. but stuff connecting is 192. i do have a repeater in the house setup, but i cannot access its settings. I don't really use the repeater.

    • Level   7

    What are the next two digits after 172.?

    e.g 172.16 or 172.31

    Don't post them all just the first two digits as you still could be double NAT'ing

    What you are seeing is normal your LAN ip address (192) should be different from your WAN ip address

    What is this repeater? It sounds like the source of the problem

    • Level   5

    Your router is still picking up an IANA address as WAN IP address. Both 192 and 172 are used for local area network (LAN) meaning, you have something prior to your router that also acts router and NAT. Do you by any chance have a Nanostation or similar?