This question has suggested answer(s)

ICMP Error

  • Level   1


As of Monday I haven't been able to connect to xbox live due to an ICMP error. Sunday it worked absolutely fine. I noticed there was some issue that you were fixing on monday so I paid no mind to it and tried after the problem had been 'solved' yet it still won't work for me. I noticed others have the same issue. My internet runs perfectly, I've spoken to two representatives from xbox who havent helped me, spoken to 2 Time Warner representatives and they haven't been able to find any issue. So please look into this. 

All Replies
    • Level   4


    Solution 1: Restart your network hardware

    1. Turn off your Xbox 360 console and network hardware (for example, your modem and router).

    2. Wait 30 seconds.

    3. Turn on your modem and wait for it to come back online (about a minute).

    4. Turn on the next piece of hardware (for example, a router), and wait another minute.

    5. Repeat step 4 for every additional piece of network hardware.

    6. Turn on your console.

    7. Press the Guide button on your controller.

    8. Go to Settings and select System Settings.

    9. Select Network Settings.

    10. Select Wired Network or the name of your wireless network, if you are prompted to do so.

    11. Select Test Xbox LIVE Connection.

    If you get the same ICMP error, try the next solution.

    Solution 2: Try a modem connection

    Try connecting your Xbox 360 console directly to your modem instead of through a router or gateway. Here’s how:

    1. Plug one end of a network cable into the back of your console and the other end into your modem.

    2. Test your Xbox LIVE connection as follows:

      1. Press the Guide button on your controller, go to Settings, and then select System Settings.

      2. Select Network Settings.

      3. Select Wired Network or the name of your wireless network, if you are prompted to do so.

      4. Select Test Xbox LIVE Connection.

    This step helps determine the cause of the problem, but is not meant to be a permanent solution. If you can connect to Xbox LIVE when you are using a direct modem connection, there is a compatibility issue with your router or gateway and the Xbox LIVE service. Contact the manufacturer of your router or gateway for help troubleshooting this problem.

    If you cannot connect to Xbox LIVE when you are using a modem connection, contact your Internet service provider for help troubleshooting this problem.

    • Level   3

    what Router do you have?

    • Level   1

    I've tried all of the above...and more. I currently have Road Runner as my internet provider and a few months ago they came in and installed some new modem by Ubee. Everything worked fine up until Monday when this ICMP error happened. I changed no settings or anything to how my modem and router are set up. I've contacted my internet provider twice and they haven't found any this is why I'm stuck. As I said before everything was working then I turned on my xbox on Monday and this issue came about.

    • Level   1

    From this forum post:

    "You can actually get into the UBEE Router settings to change them just connect on pc or tablet go to login to the router using the user and password "user" and you can get right on in. check your settings under gateway and wireless and if you decide it works better to set up a static ip get your ports forwarded accordingly :) 53, 80, 88, (MW3) 3074 and the range of 27000-27050"

    From what I gather the default setup from TWC blocks the ports you need for Xbox LIVE. Whether on purpose or not I don't know. Apparently you can log in to the UBEE router and change the settings as per above or go so far as to set it to bridged mode and use your own router. I hope this information helps...

    Xbox LIVE Community Ambassador, Beta Tester, and Microsoft Certified Professional

    • Level   5

    SoG Watchman
    From what I gather the default setup from TWC blocks the ports you need for Xbox LIVE.

    Source/link please!

    • Level   5

    Greetings SoG!

    Appreciate if you could post up the Ubee model number and the make and model of your router as well. Could you confirm that you have tried a direct connection to your modem with the Xbox.

    I have notice a couple of issues related to ICMP since the beginning of this week. However, I do not know if they are all related to the same ISP (which they all should be in such case).


    • Level   1

    It's a Ubee Modem not a router. I have a D-Link 406 Router, which connects to an apple airport. Dont know if that helps at all.

    • Level   1

    I have this issue as well. Just spent all day troubleshooting with no luck. Please look at my post titled " Server Connection Issue" from about 5 mins ago.

    My issue is identical, just with different hardware and a different provider

    • Level   5

    Can you confirm that you have tried a direct connection to your modem with your console. Please, post up the model number of your Ubee modem.

    Since you have multiple levels of NAT (D-link DI 604 + Apple Airport) have you set up one of these devices to act as an Access Point?

    • Level   3
    • Suggested Answer

    do you run the latest Firmware for your router?

    Is there an Firewall Option called aloow ping to wan or respond to ping on wan? This option is ICMP.

    • Level   1

    Allow to ping WAN port is there I see under the D-Link Router. Does this have to be changed?

    • Level   5

    @SIR i R4W DOG If you try fill in from my questions, then maybe we have a chance to better help you.

    • Level   1

    Yes I've tried a direct connection. When I plug it into the modem I get a 169 IP and it can't even connect to the internet. It's a Ubee Modem DVW3201B.

    • Level   1

    I have a D-Link DL-614+ and have the exact same ICMP response error, I do get a connection when directly plugged into the modem though.

    • Level   5

    @jah1021 Visit D-link webpage and make sure your router is up-to-date with the latest version of firmware. Afterwards, reset you router back to factory defaults.

    Post back and let us know how it goes.