This question has suggested answer(s)

MTU Error

  • Level   1
I got an Xbox 360 slim for xmas, and it has been working fine al this time. tonight I was playing online and it randomly kicked me off xbox live. I tried to reconnect and tested the connection and it said it was an MTU error. I followed what I had to do to fix the issue and it didn't work. checked my MTU settings and it was at the max it can be which was 1492. don't understand why I cant connect as my boyfriend has the old xbox 360 and he is able to connect to the internet just fine. I even tried to change internet cords to see if it was a cord issue, and it still said MTU Error. Please Help, this is driving me insane.
All Replies
    • Level   1

    I am currently having the same issue. If I do the "Test Xbox LIVE Connection" in Network settings, I get an "MTU Error". We have tried several network configurations but seeing the same results. We have wiresharked the xbox and saw the traffic. We noticed that it was making a DNS request to "" which resolved to We also tried this with a production xbox and it sent a request to "" which resolved to It then sends UDP packets to this IP address which are for the  MS MTU Test that the xbox does. The first IP ( doesn't have a reply and throws a MTU Error. The second IP ( ) has a reply and seems to work properly, it connects to Xbox Live. I'm not sure why the development xbox is second UDP packets to a different address. Anyone here know how this could be fixed?

    • Level   4
    • Suggested Answer

    Hey there! :)


    Have you followed the solutions on the Connection Error support page for the MTU errors? If so, please post back with the following information:


    What Country/State/Province do you live in? 
    Modem brand & model number: 
    Router brand & model number: 
    If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter?
    Things you have tried: 
    Is UPnP Enabled? Yes/no/Unknown
    Do you have a NAT error? If so, what is your NAT?
    Any Error Codes you encounter: 
    Who is your ISP(Internet Service Provider)? 
    After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)


    Post back and let us know how it goes, thanks! ^_^

    • Level   1

    We're seeing this exact same problem on our dev boxes: UDP packets to disappear; traceroutes seem to show a routing loop inside the MSN network. Our production box is hitting and is fine. We noticed for the first time last Monday.

    Toronto, Ontario area. Wired directly into a cruddy Rogers branded DOCSIS 2.0 router.

    • Level   4

    My apologies, here is the Connection Error support page I mentioned.

    • Level   5

    HItherClient706 and HallowedCube7 This works best if you both create your own threads so that we can focus solely on your respective issues.

    Detailing out your situation including any troubleshooting steps you have tried so far and the requested inromation DarkLink 900 asked for. This will help us to provide you with the very best support possible. Thank you!

    • Level   5

    Information, sorry!

    • Level   1

    Cool, I'll open a new thread. Hither's my coworker, which might explain why the issues look so similar :)

    • Level   1

    Mines working now. we can both play again. I fixed it the same night I had the issue haha. I was stuffing around with the router settings, switching a few things off and on and making sure everything was right. Went back on that same night I had the issue and was able to play again. Not sure how/ what I did to fix it.

    • Level   4

    Ah right, well I am glad the issue is resolved! Thank you for letting us know! ^_^