This question is answered

My XBOX can't get an IP address from my new DSL modem

  • Level   1

I am trying to get my XBOX 360 to communicate to XBOX Live.

Current problem:
I am unable to get an IP address on my XBOX from my DSL modem.

Please read the list of things I have tried (at bottom) before making suggestions. Thanks.

I am an American living in Recife, Brazil. I purchased my XBOX in the US several years ago and have gotten it to work there and here in Brazil before. I recently moved to a new building and got new internet service.

What Country/State/Province do you live in? Recife, Brazil
Modem brand & model number: Comtrend model CT-5372
Router brand & model number: same
Network Connection Type: Wireless/Wired: wired
 If Wireless, what type of encryption are you using? N/A
If Wireless, are you using a white or black external adapter, or aninternal (Xbox 360S) adapter? N/A
Things you have tried: See bottom of this post
Is UPnP Enabled? Yes/no/Unknown: I have tried both
Is NAT Type Open?
Any Error Codes you encounter: After the failed network test, the status option shows:
W:0000 - 0008
X:4000 - 1029
Y:0000 - 0000
Z:0000 - 0000
ID:0001 - 0007
What type of internet do you have? Cable/DSL/T1/3G? : DSL
Who is your ISP(Internet Service Provider)? : GVT
After you run "Test Xbox LIVE connection" and click on "More info",what is the exact message shown on screen?
"Can't obtain an IP address from your router or modem."

I have a DSL modem with 50Mps service (IPv4 but not IPv6 at this time).

Comtrend model CT-5372 ADSL/VDSL modem and integrated router

lite  lite
name  status
=====  ======

Power  Steady
LAN4  off
LAN3  off
LAN2  Flash (rapid)
LAN1  off
Wireless Flash (rapid)
ADSL  off
VDSL  Steady
Alarm  off

The LAN2 LED represents the RJ45 jack on the back that goes to my XBOX.

I am using 100 feet of CAT-5 cable.

NOTE: One odd thing is that the DSL modem does not always recognize the 100ft cable when it is connected to the XBOX. Sometimes when I plug it in or reboot the modem, the LED flashes slowly and the XBOX reports no connection. I have to unplug the cable from the modem and plug it back in several time to get it to be recognized. All of the DSL modem's RJ45 ports are the same in this regard. Rebooting the XBOX does not seem to matter for this either.

Using this same cable I am able to get an IP address on my laptop's network adapter. I can access the internet and have confirmed that I have 50Mbps service. (I temporarily disabled my wireless connection to confirm this.)

I am able to get internet access wirelessly on other devices using my DSL modem.

So, I conclude:
1. the DSL modem is providing internet connectivity
2. the DSL modem is working as a DHCP server
3. the 100ft cable is working
4. there is no MAC-filtering issue

I have the admin password to the DSL modem and I confirmed that the DHCP table shows the wired and wireless devices I expect. No MAC-filtering is being done.

The DSL Modem appears to have no support for static IP LAN addresses.

I also have a Linksys E2000 router that I have used successfully in the past with both my laptop and the XBOX. If I connect a network cable from one of it's RJ45 ports to my Laptop's NIC port, it provides a DHCP generated address as I expect.

If I connect my XBOX to the E2000, it also receives a DHCP generated IP address as expected.

From this I conclude:
1. the XBOX's RJ45 port and NIC are working
2. the XBOX is able to properly request a DHCP address
3. I do not have an issue with needing a "flipped" network cable for the XBOX

With the XBOX connected to the DSL modem I would expect to see something like this on the XBOX under "Configure Network":

Subnet Mask:

In this example, would be DHCP assigned.

What do I get instead? After several seconds...

Subnet Mask:

I looked this up and I think it means the XBOX was unable to communicate with the DHCP server on the DSL modem. In this state, if I run the XBOX network test, it fails (of course) and reports:
"Can't obtain an IP address from your router or modem."

I have tried:

1. A static IP address on the XBOX
(When I use a static IP address on the XBOX, the "more info" page tells me that my network hardware does not support static IP addresses.)

2. Manually setting the DNS server address on the XBOX to match what works on my laptop.

3. Using automatic mode on the XBOX for DHCP

4. Using automatic mode on the XBOX for DNS servers

5. All combinations of the above

6. I have opened ports 80, 88, 3074 and 53 on the DSL modem even though I know it will have no effect until the XBOX gets an IP address it can use.

7. I have tried to "daisey-chain" my E2000 router off of the DSL modem. That is to say I connect a network cable from one of the LAN ports on the back of the DSL modem to the "internet" port on the back of the E2000 router. I have not been able to get internet connectivity on the E2000 router.

8. Turning off the DSL modem and XBOX... waiting... turning on the modem... turning on the XBOX.

9. I have tried using the MAC address (a.k.a. the physical address) of my laptop NIC as the alternative MAC address setting on the XBOX.

10. The DSL modem's LAN setup with UPnP enabled

11. The DSL modem's LAN setup with UPnP disabled

12. I have tried all of the RJ45 ports on the back of the DSL modem

13. I have ordered a wireless adapter but I do not have high hopes that it will fix the problem. It will take it two or three weeks to get here.





Verified Answer
    • Level   7
    • Verified Answer
    • Verified by

    Hi, well done on a very detailed post :)

    From the I would conclude it is an issue with the cable itself, does the cable have all of the pins wired? I have seen cables work fine for a PC but not for the Xbox. You've already tried a similar thing with the Linksys but... as a test use a different shorter cable direct to the Comtrend if that works ok you know it has to be that long cable that is the issue (not the distance I just mean that particular cable)

All Replies