This question has suggested answer(s)

Can't get games to load / play... Keeps dashboarding

  • Level   1
I have had this xbox one since day one all my games would play perfectly at first, now since the update (bout a week or 2 ago) only 3 out of my 10 games will work. I go to start the game and it will show the first splash screen and just kick back to the dashboard. I have been following this forum for weeks looking at posts and trying things that are recommended to fix the issue and none of it has worked. What's the deal Microsoft? You haven't even acknowledged the problem even though it's very apparent there is one. What can I do? Any help here? Ryse: son of Rome - disc based - doesn't work NBA 2k14 - disc based - works perfectly Dead rising 3 - disc based - doesn't work Need for speed rivals - disc based - doesn't work Call of duty ghosts - disc based - works perfectly Forza motorsport 5 - disc based - doesn't work Battlefield 4 - disc based - doesn't work Assassins creed 4 - disc based - doesn't work Killer instinct - download title - works perfectly Peggle 2 - download title - doesn't work
All Replies
    • Level   5
    • Suggested Answer

    L0 Mann,

     In order to better assist you it would help if we knew what troubleshooting steps you have taken thus far. One thing you can try is power cycling your console by holding the console power button for 8 seconds until it turns off, then wait 30 seconds, then turn the console back on. Power cycling will clear the cache which might be causing the problem for you. Let us know if this works as well as any other things you have tried and we will try and assist you.

    Like my answer? "Like" my post!

    Customer Service Is Not a Department... It's an Attitude!

    • Level   1

    I have tried a few times doing the power cycle method and it has not fixed the issue. Also, I have tried uninstalling the games, power cycling the console and then installing them again but that has not worked either. I have unplugged the console a few times also and let it sit for a bit then plugging it back in again but that did nothing either. It seems like an issue that's only going to be solved by a system update. Is there any way to downgrade back b4 the update? because it seems like the update is what caused my problem.

    • Level   1

    same problem here with FIFA 14.

    • Level   1


    I've solved with the manual update suggested by Microsoft Support for other issues.

    Now Fifa 14 works well.

    • Level   1

    Could you copy the manual update here s3rp46? I'm having the same issue with Dead Rising 3 and Peggle 2.

    • Level   1

    What do you mean manual update?

    • Level   1

    I tried another option I uninstalled one of the games then disconnected my xbox one from the internet then installed the game again tried playing it offline after it finished and it still didn't work. Then I connected my xbox one back online downloaded the update to the game and tried it again but didn't work of course. Wtf!?!?

    • Level   2

    **********here the real fix and i'M not working for microsoft.********

    yes i contact microsoft a lot of time about this issue.

    FIrst Fix: put your console in english with USA as location

    Second fix: press the start button at the same time of the power button keep it for 10-15 second.

    xbox will restart or close then restart and it should work.

    the first fix resolve all my problem

    try this buddy it will work fine.

    i should work for microsoft LOL

    let me know if it's helping you

    • Level   1

    That did not work for me. This issue is really f'in annoying as I spent so much money on the system and 10 games to only be able to play 3 of them

    • Level   1

    If your games were all working perfectly before, and they started to 'break' after the last update.  Then you may have a corrupt file in your update.  Download the update again and manually apply it from:  Browse to

    Good luck and happy gaming!

    Lewis Therrin

    I drank what?!?!?!